0

I am trying to help a friend of mine fix his Debian installation on his laptop. He has installed Debian Wheezy 7.8.0 i386 netinst from a CD. His laptop is a Packard Bell Easynote R6510 using an external USB wireless card, model Asus USB N13 adapter N3000.

During the installation he had no network cable attached and the whole installation worked using his wireless card. So, Debian could recognize and use the card correctly.

After completing the installation, he rebooted the system and now the card could not be recognized any more. If he clicks on the network icon in the gnome top bar, he gets a message: "Wireless is disabled by hardware switch".

He did not switch his wireless card off after the installation so we assume it is a configuration problem. Is there a way to fix the configuration so that the card can be used as during the installation?

EDIT

Here is the output of ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:40:d0:74:3a:d3  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:10 Base address:0xa100 

eth1      Link encap:Ethernet  HWaddr 00:e0:98:42:20:7c  
          inet addr:192.168.1.70  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2e0:98ff:fe42:207c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3696 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1689 errors:0 dropped:0 overruns:0 carrier:0
          collisions:19 txqueuelen:1000 
          RX bytes:3976612 (3.7 MiB)  TX bytes:226713 (221.3 KiB)
          Interrupt:11 Base address:0xa300 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1200 (1.1 KiB)  TX bytes:1200 (1.1 KiB)

Note that the laptop has two ethernet cards, one of which is connected to a router via a cable.

EDIT 2

Here is what I found in the /var/log/messages file from the last boot (a few minutes ago). I just paste the lines that mention the wireless card, at least, the ones that we have found.

...
Apr  5 22:18:01 batman kernel: [   10.662012] rtl8192cu: MAC address: ac:9e:17:78:1a:74
Apr  5 22:18:01 batman kernel: [   10.662029] rtl8192cu: Board Type 0
Apr  5 22:18:01 batman kernel: [   10.818286] usb 1-2.2: firmware: agent loaded rtlwifi/rtl8192cufw.bin into memory
Apr  5 22:18:01 batman kernel: [   10.819057] rtlwifi: rx_max_size 15360, rx_urb_num 8, in_ep 1
Apr  5 22:18:01 batman kernel: [   10.819363] cfg80211: Calling CRDA for country: US
Apr  5 22:18:01 batman kernel: [   10.835532] cfg80211: Regulatory domain changed to country: US
Apr  5 22:18:01 batman kernel: [   10.835543] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Apr  5 22:18:01 batman kernel: [   10.835554] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm)
Apr  5 22:18:01 batman kernel: [   10.835565] cfg80211:     (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 1700 mBm)
Apr  5 22:18:01 batman kernel: [   10.835574] cfg80211:     (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm)
Apr  5 22:18:01 batman kernel: [   10.835584] cfg80211:     (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm)
Apr  5 22:18:01 batman kernel: [   10.835594] cfg80211:     (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
Apr  5 22:18:01 batman kernel: [   10.890421] usbcore: registered new interface driver rtl8192cu
...

From what we have found in the documentation, rtl8192cu is the driver of the wireless card.

EDIT3

Here is the content of the file /etc/udev/rules.d/70-persistent-net.rules:

# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x10ec:/sys/devices/pci0000:00/0000:00:1e.0/0000:02:02.0 (8139too)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:40:d0:74:3a:d3", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCMCIA device 0xc1ab:0x0149 (pcnet_cs)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:e0:98:42:20:7c", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

# PCI device 0x8086:/sys/devices/pci0000:00/0000:00:1e.0/0000:02:01.0 (ipw2200)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:12:f0:3a:eb:65", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"

# USB device 0x:0x (rtl8192cu)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="ac:9e:17:78:1a:74", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

While ifconfig only reports the devices lo, eth0 and eth1 (as described above), if I run iwconfig I get:

lo        no wireless extensions.

eth2      IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power=off   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth1      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:on

eth0      no wireless extensions.

EDIT 4 - PROBLEM SOLVED

Using your hints, we managed to solve the problem in the following way. The file /etc/udev/rules.d/70-persistent-net.rules lists two wireless cards, namely eth2 with driver ipw2200, and wlan0 with driver rtl8192cu. We solved the problem by disabling eth2: we added the kernel module ipw2200 to the blacklist file /etc/modprobe.d/blacklist.conf.

We had this idea because rfkill reported eth2 as being hard blocked. Now the external wireless device wlan0 works properly.

We do not know why the second card did not work when the first one was blocked. Any idea?

Thanks to Faheem Mitha for the useful hints: without your help we wouldn't have been able to solve the problem.

  • Can you post the output of ifconfig? – demonking Apr 5 '15 at 20:12
  • 1
    To start with, take a look at dmesg and see if there is any mention of the card. I assume the card has remained plugged in the whole time? – Faheem Mitha Apr 5 '15 at 20:30
  • @FaheemMitha: The card remained plugged in the whole time. – Giorgio Apr 5 '15 at 20:32
  • 1
    Try removing the cable and bringing down and back up the interface belonging to the wireless card manually using ifdown eth1 and ifup eth1, (assuming the wireless card orresponds to eth1). See what messages are sent to standard output and also what are produced in the logs. Post relevant information, including the output if the interface seems to come back up correctly. Logs to check are /var/log/syslog, /var/log/messages, and /var/log/kern.log.I'm also wondering where that 192.168.1.70 comes from. – Faheem Mitha Apr 5 '15 at 21:13
  • 1
    You need to figure out what the interface is. It is probably either wlan0 or wlan1. Does the system have a file called /etc/udev/rules.d/70-persistent-net.rules? If so, what is its contents? Also, check if there is any mention of wlan0 or wlan1 in any of the logs, or in dmesg. – Faheem Mitha Apr 5 '15 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.