0

Ive followed all the steps in https://help.ubuntu.com/community/Postfix/DovecotLDAP but I am getting a

localhost postfix/smtpd[12520]: fatal: no SASL authentication mechanisms

in my /var/log/mail.err

Is there a way to find out more specific root cause?

Note: I have verified saslauthd is running properly using testsaslauthd. SASLAuthd is running fine. I'm struggling in trying to get deeper logs and exact cause on the postfix-sasl side, since I assume the issue will be there.

0

I managed to fix it. RCA were:

  1. SASLauthd service was initially not running. I verified that by performing testsaslauthd

  2. dovecot service was not running: dovecot not starting : service(imap) access(/usr/lib/dovecot/imap) failed. This was preventing postfix from connecting via SASL. As a result telnet on 25 was also failing.

Troubleshooting steps:

  1. Verify service status using service dovecot status, service postfix status, testsaslauthd. To identify and isolate the problem
  2. If SASLAuthd is using "pam" as a MECH then you may want to try a direct MECH like "ldap" in my case.E.g: Shutdown sasldservice and saslauthd -a ldap -V
  3. Look into your logs @ /var/log/mail.err and /var/log/auth.log for details
  4. Verify configs are fine by postconf -n and dovecot -n
  5. Fix individual service errors. Note: service errors will only occur when you try to start the service, not execute. So Step 1 & 3 are essential not to miss any stupid startup issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.