0

I have a HP laptop with Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter. The laptop came with Windows 8.1 and the wifi worked just fine, but since I wanted to try Linux, I installed Ubuntu, and the wifi worked super slow, and it was unstable, so then I thought that installing Fedora might fix the problem, but it didn't.

So I started reading everywhere in forums and I found out that this solution has helped a few people: (I'm on Fedora now btw)

git clone http://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo modprobe -rv rtl8188ee
sudo make install
sudo modprobe -v rtl8188ee

but whenever I type the 'make' command I get the following result:

make -C /lib/modules/3.17.4-301.fc21.x86_64/build M=/home/Betim/rtlwifi_new modules
make[1]: *** /lib/modules/3.17.4-301.fc21.x86_64/build: No such file or directory.  Stop.
Makefile:53: recipe for target 'all' failed
make: *** [all] Error 2

can somebody please help me, because I really like Fedora, and I want to stick to it, I would hate to go back to Windows...

  • you dont have kernel header files. sudo yum install kernel-devel kernel-headers – Milind Dumbare Apr 1 '15 at 12:28
  • Thanks for the comment, I just did that, and I still get the same message.. – BetimNeutron Apr 1 '15 at 13:11
  • How does your /lib/modules/3.17.4-301.fc21.x86_64/build look like? And how does your /usr/src/ look like? – Milind Dumbare Apr 1 '15 at 13:15
  • Make sure you're running the kernel version that you installed the devel package for. That command will install the newest version by default, and that might not match what you are running, and it appears the build process picks up the version info from the running kernel. – mattdm Apr 1 '15 at 13:16
  • @Miline Sorry, I am such a noob, thanks for hanging with me. For the first command I got: bash: /lib/modules/3.17.4-301.fc21.x86_64/build: No such file or directory and for the second : bash: /usr/src/: Is a directory – BetimNeutron Apr 1 '15 at 13:19
2

So, the core problem there is that it's looking for the kernel header files needed to compile new kernel modules. You can install those with

sudo yum install kernel-devel

But the further trick is that the compile process is looking for kernel devel files which match your running kernel. You can run uname -r to find the currently-running kernel, and rpm -q kernel-devel. By default on an updated system, you will probably have multiple kernel versions installed, because the update system saves the last two for safety. But, unless you've rebooted after the last update, you may not be running the latest one. By contrast, the kernel-devel package is usually kept to the latest (and that's what you'll get with the yum install command above).

So, if you reboot, you should have the newer kernel both installed and running, and when you run make, you'll see it looking for the newer version instead of 3.17.4.

That said, there is a note on the github repo you've linked which says that fixes for slow speed were slated to go into the 3.18 kernel, and since we're at 3.19.3 now, it is very likely that simply updating alone will fix your issue.

(Disclaimer: I work on Fedora for my job, so I'm not unbiased, but I do want to add that our awesome kernel team does a great job of tracking the latest upstream kernel very closely and quickly, and rolls those updates out across all of our currently-supported releases, making Fedora a great choice for hardware-enablement issues like this.)

  • Thanks for your help, and your time. I think that it is pretty cool that you work for Fedora, because I really fell in love with the system. Because I hate to be a pain in the ass, and waste peoples time, I think that I am just going to switch back to windows, because eventhough I did everything that I was supposed to do, I still get the same message. Sorry that I cannot upvote your post, because I have a below 15 reputation, it seems like it is not possible to do it.... – BetimNeutron Apr 1 '15 at 13:48
  • @BetimNeutron Is your speed better with the newer kernel? – mattdm Apr 1 '15 at 14:04
  • Asking for help isn't annoying, by the way. We all have to start somewhere! – mattdm Apr 1 '15 at 14:05
  • thanks... I can't really tell since it is inconsistent, it may be fine now, but a minute later note. This is the current result :speedtest.net/my-result/4257669044 is it okay that the upload speed is that much higher? And what bothers me so much is that eventhough I have the newest kernel, that 'make' still goes and looks for the older one 3.17...go figure – BetimNeutron Apr 1 '15 at 14:16
1

The basic problem was you do not have kernel headers installed. If you do sudo yum install kernel-devel kernel-headers and boot into the new installed kernel. Then your driver make will be able to find your kernel headers in /lib/modules/{uname -r}/build

  • Thank you sooo much for your help. I still get the same error message though, anyway I don't want to be annoying or anything, I think that I am just going to switch back to Windows... – BetimNeutron Apr 1 '15 at 13:47
  • Ohh and btw, I cannot upvote your post either, because it seems like that is impossible to do if you have a reputation below 15 (and I do since I am new here).. – BetimNeutron Apr 1 '15 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.