0

I am trying to install deb package in a new AWS 14.04 ami instance, but it fail with the following error -

The following packages have unmet dependencies:
youtube-snapshot-taker : Depends: firefox (= 35.0.1+build1-0ubuntu0.14.04.1) but 36.0.4+build1-0ubuntu0.14.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.
The deb was package with fpm and his deb-dependencies are -
Depends: python-virtualenv, python-pip, python-dev, xvfb, firefox (= 35.0.1+build1-0ubuntu0.14.04.1), openssl, build-essential, xorg, libssl-dev, libxrender-dev, libqt4-dev, qt4-dev-tools, wkhtmltox, libxml2-dev, libxslt1-dev

I checked that firefox is not already installed (dpkg -l).
I have no idea what is the problem.
Thanks for helping!

0

The line is to be installed means that Firefox 36 is the only version available in the repositories. The package depends on Firefox 35, which isn't available, so apt can't install the package.

There's some information in this question about installing a package while ignoring some dependencies: https://serverfault.com/questions/250224/how-do-i-get-apt-get-to-ignore-some-dependencies

  • Actually I forgot to write it, but i checked it already with - apt-cache policy firefox. and the instace has those two versions. – avivb Apr 1 '15 at 17:43
0

You may try to install your package with the following steps (if you're installing the separate .deb package, not from repositories via APT tools):

  1. Install the package itself via: dpkg -i /path/to/package.deb. It seems that you've performed that action yet.
  2. If you'll have some unmet dependencies like in your message you have, run the following: aptitude install -f or apt-get install -f. These commands will resolve your dependency errors and you'll successfully install your package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.