0

I work under Debian Testing with Gnome shell 3.14.2 on a Lenovo Thinkpad X1 Carbon (3rd gen.). I would like to create a custom 'screenshot' command based on scrot:

scrot -s -b '%Y-%m-%d_%H:%M:%S_screenshot.png' -e 'mv $f ~/Myfolder'

I put this line in a file .scrot.sh and created the Shortcut command via /bin/sh ~/scrot.sh. Furthermore, I uses "Print" as the triggering shortcut (so simply pressing PrtScn). However, no screenshot is produced. Why? And how can this be fixed?

0

... the bug behind is pretty bad... I found this post which links to enter link description here. To make it short, the command is indeed /bin/sh /path/to/script where script is a shell script containing

scrot -s -b '%Y-%m-%d_%H:%M:%S_screenshot.png' -e 'mv $f /home/$USER/Myfolder'

... but assigning this to a shortcut via Settings -> Keyboard -> Shortcuts -> Custom Shortcuts did not work because of a bug in scrot (?); see the above links. A workaround was to add sleep 1; right before scrot.... So this works for now. Pretty bad hack, though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.