3

I have a laptop with this hardware:

  • intel i5
  • nvidia 820m graphics card
  • 64bit system with uefi boot

I burned the Arch Linux ISO to USB, and I am getting the option to choose Arch on booting the USB, but its not starting.

Instead I'm getting this error:

unknown chipset error

  • that's a very vague error... – user236012 Mar 31 '15 at 13:06
  • 1
    Fermi is your NVIDIA chipset. Can you disable it in BIOS and try without it? – petry Mar 31 '15 at 13:22
  • @petry tried that, getting different error – Edward Torvalds Mar 31 '15 at 13:34
  • Are you using the latest Arch bootable image? – teppic Mar 31 '15 at 14:10
  • Try adding 'nomodeset nouveau.modeset=0' to the boot options. – teppic Mar 31 '15 at 14:17
4

The problem here is that by default Arch boots up with kernel modesetting for the display (and console), using the open source nouveau driver. It seems that the driver included in this kernel doesn't support your graphics chipset, and rather than fallback, it simply gives you no console display.

To disable kernel modesetting you can edit the boot options in the boot menu and add the following

nomodeset nouveau.modeset=0

It's possible that it will work with the latest kernel once you update Arch. However, if you install the official nvidia drivers this will not be necessary, as nouveau isn't used any more.

  • hey nouveau is used on my ubuntu for nvidia graphics card – Edward Torvalds Mar 31 '15 at 17:01
  • @edwardtorvalds Different kernels, etc. The current Arch kernel is more recent than the latest bootable image, so try updating. – teppic Mar 31 '15 at 20:57
-1

This error can be very misleading, and it has nothing to do with your nVidia chipset. In many cases its caused by an NTFS partition which was not completely unmounted. The solution can be turning the Fast startup off in Windows (http://www.eightforums.com/tutorials/6320-fast-startup-turn-off-windows-8-a.html).

  • the image shows Fermi chipset, and my nvidia comes with fermi chipset – Edward Torvalds Dec 21 '15 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.