11

When I boot, or when I press CtrlAltF*, I am taken to a physical terminal/TTY. The problem is that the TTY shows up on my HDMI monitor, which is actually not even in the same room as me.

Is it possible to configure my PC to display the TTY on my DisplayPort monitor? To clarify, when I press CtrlAltF1, I want the TTY to show up on my DisplayPort monitor, not my HDMI monitor.


EDIT: After some more digging it looks like the bootloader might be involved here, so I should specify I'm using GRUB 2.02~beta2-20

1 Answer 1

2

Assuming the kernel is configured to support the frame buffer console, You can specify which fb driver to output the console on via fbcon in the kernel args. For example:

fbcon=map:1

You can find out which fb driver values are available using:

cat /proc/fb

In GRUB 2, the fbcon parameter can be appended to GRUB_CMDLINE_LINUX.

For more information, see: https://www.kernel.org/doc/Documentation/fb/fbcon.txt

3
  • cat /proc/fb outputs nothing for me, does that mean my kernel isn't compiled with frame buffer console support?
    – Hubro
    Commented Mar 31, 2015 at 22:48
  • Not necessarily, but its possible depending on the display driver you are using. Nothing shows up here since your display driver is not registering as a framebuffer device. Most likely the driver runs using KMS only. In some cases, it is often necessary to set CONFIG_FRAMEBUFFER_CONSOLE=y in the kernel config to utilize fbcon - a known bug as acknowledge here: wiki.debian.org/KernelModesetting.
    – shibley
    Commented Apr 1, 2015 at 0:54
  • If cat has no output, you can set up framebuffer by following these instructions. Reboot to apply the changes before you run cat again.
    – mchid
    Commented Jun 10, 2021 at 4:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .