2

I'm running on Centos 6.2 x86_64

Trying to install ruby 2.1.2

---> Package libselinux-devel.x86_64 0:2.0.94-5.2.el6 will be installed
--> Processing Dependency: libsepol-devel >= 2.0.32-1 for package: libselinux-devel-2.0.94-5.2.el6.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.0.94-5.2.el6.x86_64
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package keyutils-libs.i686 0:1.4-3.el6 will be installed
---> Package libselinux.i686 0:2.0.94-5.2.el6 will be installed
---> Package libsepol-devel.x86_64 0:2.0.41-4.el6 will be installed
---> Package nss-softokn-freebl.i686 0:3.12.9-11.el6 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: openssl-1.0.0-20.el6.i686 != openssl-1.0.1e-16.el6_5.7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

If I get the installed packages:

[root@test tmp]# rpm -qa | grep openssl
openssl-1.0.1e-16.el6_5.7.x86_64
openssl098e-0.9.8e-17.el6.centos.x86_64

I didn't see that openssl-1.0.0-20.el6.i686

How can I remove it?

0

The error means you are trying to install a different version for one architecture than you have installed for the other. The solution is to upgrade the current version of your package to the version that will be installed for the other architecture. In your case, that would mean downgrade openssl-1.0.1e-16.el6_5.7.x86_64 to openssl-1.0.0-20.el6.x86_64 then try the command again, but that is not optimal. Instead, you might have some repos disabled that you need to enable to get the right version of the package for both architectures.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.