3

EDIT: 2015-03-29 16:14 UTC+1: After downloading the images, the VM throws the error "Failed to mount RPC Pipe Filesystem"

I am trying to do automatic installation of CentOS 7 via PXE.

My PXE server defaults everything to the CentOS 7 install, since this is testing:

My /srv/tftp/pxelinux.cfg/default:

#prompt 1
timeout 600

default centos7
label centos7
    menu label ^Install CentOS 7
    kernel centos/images/pxeboot/vmlinuz
    append vga=normal initrd=centos/images/pxeboot/initrd.img ks=http://**.***.**.***/kickstart7.cfg priority=critical IPAPPEND 2

The files in my /srv/tftp/centos/images/pxeboot seem to be OK:

root@dvxtest:/srv/tftp/centos/images/pxeboot# md5sum *
b643733cacd1a8b6715f00ba669e69ed  initrd.img
064652e5c5e03bdc96f7b7b10d1c5c61  TRANS.TBL
b76341074e5d68b4e315d00b29fb11fb  upgrade.img
1f8a3bc847320572e531251fbf7e546b  vmlinuz

I've readen on the official CentOS forums that it might be the wrong file booting, so I just downloaded the complete CentOS install dvd iso-file and mounted using this instead of unpacked files.

When I start my VM it seems to be OK:

Trying to load: /pxelinux.cfg/default    ok
Loading centos/images/pxeboot/vmlinuz.......
Loading centos/images/pxeboot/initrd.img....................................

After that it downloads all needed files from the given repository with the warning that "update.img" and "product.img" does not exist. According to https://bugzilla.redhat.com/show_bug.cgi?id=722409 this should be OK because "product.img" is RHEL related and "update.img" is only needed in "certain cases"

After this my VM throws the error "Failed to mount RPC Pipe File System" while booting, then starts the live-login

My kickstart.cfg:

# System authorization information
auth --enableshadow --passalgo=sha512
# Use network installation
repo --name=base --baseurl=http://mirror.cogentco.com/pub/linux/centos/7/os/x86_64/
url --url="http://mirror.cogentco.com/pub/linux/centos/7/os/x86_64/"
# Run the Setup Agent on first boot
firstboot --enable
ignoredisk --only-use=sda
# Keyboard layouts
keyboard --vckeymap=sg --xlayouts='ch'
# System language
lang de_CH.UTF-8

# Network information
network  --bootproto=static --device=enp4s0 --gateway=192.168.100.1 --ip=192.168.0.130 --nameserver=192.168.100.1 --netmask=255.255.255.0 --ipv6=auto --activate --hostname=roflcopter.lh
# Root password
rootpw --plaintext test123
# System timezone
timezone Europe/Zurich --isUtc
# System bootloader configuration
bootloader --location=mbr --boot-drive=sda
autopart --type=lvm
# Partition clearing information
clearpart --all --initlabel --drives=sda

%packages
@core

%end

What I tried until now:

Until now, I'm completely clueless of what the problem could be and I'm not even sure on how to debug it.

I'm sorry if I might have forgotten any useful information, please just tell me and I will provide it.

Any help is appreciated

Thank you for your time.

1

I found the answer, but I can't explain the "why" since it doesn't make any sense and/or I am not understanding the documentation. I'm still going to post it as the answer so if anyone else has the same problem he will have another thing to try out on his "try & error"-trip.

Documentation: http://www.syslinux.org/wiki/index.php/SYSLINUX#APPEND_-

Removing the IPAPPEND 2 from the end of the default file in the centos installation label actually solved the issue.

I can reproduce the error, adding back IPAPPEND 2 makes it stop working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.