3

Are these dnsmasq.conf options fine:

port=0
interface=enp0s20u2u1
bind-interfaces
dhcp-range=192.168.2.50,192.168.2.220,12h
dhcp-boot=boot/syslinux/lpxelinux.0
dhcp-option-force=209,boot/syslinux/pxe.cfg
dhcp-option-force=210,/
enable-tftp
tftp-root=/mnt/pxe/

My problem is that syslinux (version 6.03) doesn't boot into the kernel. I am stuck at syslinux blue boot menu, after pxe boot retrieved the network information from the dhcp server and syslinux bootloader popped up.

This is my pxe syslinux config:

# Default boot option to use
DEFAULT menu.c32
# Prompt user for selection
PROMPT 0
# Menu Configuration
MENU WIDTH 80
MENU MARGIN 10
MENU PASSWORDMARGIN 3
MENU ROWS 12
MENU TABMSGROW 18
MENU CMDLINEROW 18
MENU ENDROW 24
MENU PASSWORDROW 11
MENU TIMEOUTROW 20
MENU TITLE 64Bit (x64) OS Choice
# Return to Main Menu
LABEL MainMenu
  MENU DEFAULT
  MENU LABEL ^Main Menu
  KERNEL menu.c32

LABEL rear_nfs
  TEXT HELP
  Boot REAR. Allows you to recover bare metal.
  ENDTEXT
  MENU LABEL Boot PXE rear
  KERNEL ../phlaplen.kernel
  INITRD ../phlaplen.initrd.cgz

I assume syslinux doesn't find my kernel nor initrd file.

In following tree output you see the directories and files of my TFTP root (path specified in dnsmasq.conf).

tree                                                                                                                                                                     
.
|-- boot
|   |-- phlaplen.initrd.cgz
|   |-- phlaplen.kernel
|   `-- syslinux
|       |-- altmbr.bin
|       |-- altmbr_c.bin
|       |-- altmbr_f.bin
|       |-- cat.c32
|       |-- chain.c32
|       |-- cmd.c32
|       |-- cmenu.c32
|       |-- config.c32
|       |-- cptime.c32
|       |-- cpu.c32
|       |-- cpuid.c32
|       |-- cpuidtest.c32
|       |-- debug.c32
|       |-- dhcp.c32
|       |-- disk.c32
|       |-- dmi.c32
|       |-- dmitest.c32
|       |-- elf.c32
|       |-- ethersel.c32
|       |-- gfxboot.c32
|       |-- gptmbr.bin
|       |-- gptmbr_c.bin
|       |-- gptmbr_f.bin
|       |-- gpxecmd.c32
|       |-- gpxelinux.0
|       |-- gpxelinuxk.0
|       |-- hdt.c32
|       |-- hexdump.c32
|       |-- host.c32
|       |-- ifcpu.c32
|       |-- ifcpu64.c32
|       |-- ifmemdsk.c32
|       |-- ifplop.c32
|       |-- isohdpfx.bin
|       |-- isohdpfx_c.bin
|       |-- isohdpfx_f.bin
|       |-- isohdppx.bin
|       |-- isohdppx_c.bin
|       |-- isohdppx_f.bin
|       |-- isolinux-debug.bin
|       |-- isolinux.bin
|       |-- kbdmap.c32
|       |-- kontron_wdt.c32
|       |-- ldlinux.c32
|       |-- lfs.c32
|       |-- libcom32.c32
|       |-- libgpl.c32
|       |-- liblua.c32
|       |-- libmenu.c32
|       |-- libutil.c32
|       |-- linux.c32
|       |-- lpxelinux.0
|       |-- ls.c32
|       |-- lua.c32
|       |-- mboot.c32
|       |-- mbr.bin
|       |-- mbr_c.bin
|       |-- mbr_f.bin
|       |-- memdisk
|       |-- meminfo.c32
|       |-- menu.c32
|       |-- pci.c32
|       |-- pcitest.c32
|       |-- phlaplen.initrd.cgz
|       |-- phlaplen.kernel
|       |-- pmload.c32
|       |-- poweroff.c32
|       |-- prdhcp.c32
|       |-- pwd.c32
|       |-- pxe.cfg
|       |-- pxechn.c32
|       |-- pxelinux.0
|       |-- reboot.c32
|       |-- rosh.c32
|       |-- sanboot.c32
|       |-- sdi.c32
|       |-- sysdump.c32
|       |-- syslinux.c32
|       |-- vesa.c32
|       |-- vesainfo.c32
|       |-- vesamenu.c32
|       |-- vpdtest.c32
|       |-- whichsys.c32
|       `-- zzjson.c32
|-- phlaplen.initrd.cgz
`-- phlaplen.kernel

What am I missing?

Update 1: Following Nasha's suggestion to use the absolute path, I could successfully boot the kernel. I had to use the absolute path that is specified in dhcp-option-force=210, and not the one specified in tftp-root option.

/etc/dnsmasq.conf:

port=0
interface=enp0s20u2u1
bind-interfaces
dhcp-range=192.168.2.50,192.168.2.220,12h
dhcp-boot=boot/syslinux/lpxelinux.0
dhcp-option-force=209,syslinux/pxe.cfg
dhcp-option-force=210,/boot/
enable-tftp
tftp-root=/mnt/pxe/

pxe.cfg on the tftp server.

LABEL rear_nfs
  TEXT HELP
  Boot REAR. Allows you to recover bare metal.
  ENDTEXT
  MENU LABEL Boot PXE rear
  KERNEL /phlaplen.kernel
  INITRD /phlaplen.initrd.cgz
  • 1
    Have you tried absolute instead of relative paths for kernel and initrd? Also, what is your version of pxelinux? – user86969 Mar 30 '15 at 13:14
  • Using the absolute path worked fine, thank you. I had to use the absolute path specified in dhcp-option-force=210, and not the one specified in tftp-root option. – fremon Mar 30 '15 at 19:01
  • Glad it worked. – user86969 Mar 31 '15 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.