2

In general, Waltop Evo Graphic Tablet works but I can't configure it with Wacom Tablet settings pannel (Settings>Wacom Tablet). It shows "Please plug in or turn on your Wacom tablet ..."

More info:

$ uname -a
Linux me 3.16.0-4-amd64 #1 SMP Debian 3.16.7-2 (2014-11-06) x86_64 GNU/Linux

$ lsusb
Bus 002 Device 004: ID 172f:0510 Waltop International Corp. 
<...>

I also set custom configuration in /etc/X11/xorg.conf.d/50-my-wacom.conf to use wacom driver:

Section "InputClass"
        Identifier "Wacom Waltop USB device class"
        MatchUSBID "172f:*"
        MatchDevicePath "/dev/input/event*"
        Driver "wacom"
EndSection

(After that xsetwacom started recognising it):

$ xsetwacom --list devices
Waltop International Corp. Battery-free Graphics Tablet stylus  id: 11  type: STYLUS    
Waltop International Corp. Battery-free Graphics Tablet pad id: 12  type: PAD       

I also created /usr/share/libwacom/waltop-battery-free-tablet.tablet:

[Device]
Name=Waltop International Corp.
DeviceMatch=usb:172f:0510
Class=Bamboo
Width=10
Height=6

[Features]
Stylus=true
Reversible=false
Touch=false
Ring=false
Ring2=false
NumStrips=0
Buttons=2

Could please somebody tell me what I did wrong? How to make Wacom Tablet settings pannel recognise my tablet?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.