1

Edit
Please note that I fixed the original problem of not booting, but I still can't get it to run X-windows after being prompted for language, input, and display resolution.

Original question
I read about the latest gparted, and saw this article explaining how to install it on a hard drive. Seemed like it would be a good way to both try it out and have it available, but I've been unable to get it to work. No matter what I've done, I get an immediate reboot.

I'm pretty confident that I've followed the directions correctly, and specified the correct disk/partition, etc. Here's what I've tried...

Install from hard disk partition

The partition I used was /dev/sdc8.

I mounted the partition as specified (sudo mount /dev/sdc8 /dev), and unzipped the archive into the directory (/mnt). I originally renamed the /live directory to /live-hd, as suggested, but later changed it back, because their directions seemed to sometimes get it wrong, so I didn't want to second-guess possible errors. But I got the same results either way.

I added this to /etc/grub.d/40_custom:

menuentry "GParted live" {
   set root=(hd2,8)
   linux /live/vmlinuz boot=live config union=aufs noswap noprompt vga=788 ip=frommedia live-media-path=/live bootfrom=/dev/sdc8 toram=filesystem.squashfs
   initrd /live/initrd.img
}

Then, I ran sudo update-grub2 to update my grub menu.

Boot from gparted iso

Next, I tried copying the iso file to /home/isos, and substituted this in /etc/grub.d/40_custom:

menuentry "Gparted live" {
  set isofile="/home/isos/gparted-live-0.22.0-1-amd64.iso"
     loopback loop $isofile
     linux (loop)/live/vmlinuz boot=live config union=aufs noswap noprompt vga=788 ip=frommedia toram=filesystem.squashfs findiso=$isofile
     initrd (loop)/live/initrd.img
  }

Ran sudo upgrade-grub2, rebooted, and got the same instant reboot.

I apologize if this is not the appropriate place to ask about this. I posted on the gparted forums, but the forums looked to be pretty sparse, and I've gotten no responses so far.

Edit
I managed to get the iso file to boot by adding a specifier for which partition to use for booting: loopback loop (hd0,gpt1)$isofile (my boot partition is on a gpt formatted ssd).

Unfortunately, I have not been able to get X to run so far. So now my question is how to get X up and running, something I never have trouble with using any distros so far. I am prompted for some input parameters, including display resolution and driver. I've tried various resolutions, both vesa and ATI drivers, and auto, but all result in a black screen with a flashing text cursor in the upper left corner.

  • 1
    try with line set root=(hd2,msdos8) - that is assuming that you are using an extended/logical partition. – gogoud Mar 27 '15 at 18:38
  • Thanks @gogoud; I am using extended/logical partitioning, and using msdos8 was a good suggestion although it didn't seem to be the problem. Guess I may need to dig deeper, and hope I don't fall into a black hole. – Marty Fried Mar 27 '15 at 20:10
0

Regarding your new question...

In grub menu, press c to open a command-line then type vbeinfo. Make a note of an available resolution e.g. 1366x768, then type reboot.

Back in grub menu for 2nd time, type e and add GRUB_GFXMODE=1366x768 right after load_video (or edit it if GRUB_GFXMODE= is already present) - use a resolution that you confirmed was available. It should be added to the second line. Then press F10 to boot.

If you are just installing the system, you might find that after installation it reboots fine. If not, you can make the change permanent (so you don't have this palaver every time you boot) by editing /etc/default/grub e.g.

gksudo gedit /etc/default/grub

and adding a line:

GRUB_GFXMODE=1366x768 (or whatever is appropriate in your case)

After saving this change you need to run update-grub:

sudo update-grub

Explanation: the default video mode doesn't work on your system, this forces it to use a specific video mode which you have checked is available.

As an alternative, try using SystemRescueCD which can also be installed to hard disk. This includes GParted and has a lot of other utilities too.

Lastly, are you sure you need to have GParted Live as a bootable partition on your hard disk? Can't you just keep a USB or CD handy for when you need it? This is the normal way of using it and you would make your life much simpler by going with the flow...

  • Thanks - but I think perhaps my current problem isn't clear due to advancing past the inability to boot. Maybe I should repost a new question, rather than making it more complicated. I can boot gparted, and it prompts me for language, input, and video parameters. Then, when trying to start X, it fails no matter what resolution or driver I choose. I did try your suggestion, but there's no "load_video". I added it to a separate line before loading vmlinux. – Marty Fried Mar 28 '15 at 21:27
  • As to why I don't use USB or CD... why do I need to hunt down a CD or USB stick when they provide the ability to boot from HD? And how do I know the external media will not have this same problem? The reason I want this is I wanted to use the latest version of GParted. Otherwise, I just use any Linux live CD. – Marty Fried Mar 28 '15 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.