So I installed GRUB2 and Ubuntu 14.10 alongside Windwos 8.1. I am on an Acer laptop, which does not have a cd drive.

I deleted the Ubuntu partition in windows 8.1 through the integrated disk manager, restarted and now am seeing this:

GNU GRUB version 2.02~beta2-9ubuntu1 Minimal BASH-like editing is supported.for the first word, TAB lists possible commands completions.Anywhere else TAB lists possible device or file completion grub>

I have googled some things and I think I need to restore the default Windows boot manager. However, I don't have a recovery disk for windows 8.1, and again, I don't have a cd drive.

Is another possibility to make a usb with Ubuntu on it and to boot this one instead and then somehow to fix this?

  • Yes...it is possible to do USB of Ubuntu and fix it that way, but I think my answer might be more beneficial. If it doesn't work then let me know and I'll show you a different way.
    – SailorCire
    Commented Mar 27, 2015 at 12:57
  • See also Boot windows from grub rescue command prompt Commented Mar 27, 2015 at 13:09
  • The ideal solution would be to boot into Windows, and then restore the Windows boot manager. Lets start with booting Windows. What you can do is put Super Grub2 on a USB drive and boot from it. See supergrubdisk.org. It has an "everything" option which should detect Windows and allow you to boot it. Once you get that working, we can work on the Windows boot manager. Commented Jan 7, 2017 at 16:43

6 Answers 6


I write "exit" then enter. The menu of Boot Manager shows, then I select Windows Boot Manager. It works with Windows 10


In my practice, I follow this video's guide to recovery windows boot manager from grub.

Firstly, make a linux os (like ubuntu )bootable usb stick, plug into the PC, and boot from usb, enter live mode;

Second, install lilo by

sudo apt-get install lilo

Thirdly use lilo to make master boot record of your disk partition.

sudo lilo -M /dev/sda mbr

Then should the computer boot from windows.


For me, "exit" did not work. I had to find my EFI partition by entering in the grub command line (from here):

grub rescue>  ls  
(hd0,4) (hd0,3) (hd0,2) (hd0,1)  

grub rescue>  ls (hd0,4)/boot
... some kind of 'not found' message

grub rescue>  ls (hd0,3)/boot
... some kind of 'not found' message

grub rescue>  ls (hd0,1)/boot
... grub ... initrd.img-2.6.32-33-generic ... vmlinuz-2.6.32-33-generic 

So, for (hd0,1) I had to enter at the grub rescue prompt: (from here):

insmod part_gpt
insmod chain
set root=(hd0,1)
chainloader /EFI/Microsoft/Boot/bootmgfw.efi

This brought me to the windows boot management. From there, I followed other advices to restore the windows boot manager to appear at startup. Important, because it was not my machine... In the end, I had to reformat the EFI partition and restore its content with the "bcdboot" command from a windows RE, because I had no access to that partition to use "bootrec /fixboot" (see here, in German).

Thank you, all you contributers!


What worked for me (based on the particular way I had messed up my system): Eject my SD card (I'd tried to make it a bootable disk - failed). At the grub prompt, type "exit" (as mentioned by PacoRos above). Windows booted normally! A bit of a pain, but it worked. Next step is to fix win boot.

I got into this problem after Win10 Pro Creator update trashed my grub2 choice between Win + Ubuntu, and I tried to "repair" it :-).


In my case i have a SSD Western digital in an Acer Box, Spiralinux 12.231008, kernel 6.5.0-0 when i recover my linux don't show windows 11 with command, only checking boot line from linux give pointing hardisk hd0,gpt7 so i found one combination for boot:

First i run grub customizer GUI, add menu Windows 11 and write code:

insmod part_gpt set root=(hd0,gpt1) chainloader /EFI/Microsoft/Boot/bootmgfw.efi

then i save and don't show error in "(" or "{", than it's good

In first line search type gpt, in second set the root path pointing gpt1 (vfat efi boot partition Windows 11, gpt2 is system partition, gpt3 repair partition) and chainloader go to efi kernel boot.

boot code windows 11


Well, you certainly went out of your way to not do yourself any favors. All of the config files were on your Ubuntu partition.

One temp way is to do the following at the grub propt:

    set root='(hd0,1)'
    chainloader +1

That should get you back to Windows. At that point you should be able to restore the Windows Bootloader through the command line. You'll need to goto the recovery console and do the following:

bootrec /fixboot

I haven't used Windows in a while and the above command is just from a little bit of teaching, but the grub chainloading should work (assuming Windows lives in partition 1 of the first disk drive).

  • it says "invalid EFI file path" EDIT: typed in ls. The output: (hd0) (hd0,gpt5) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1)
    – David D
    Commented Mar 27, 2015 at 12:58
  • @DavidD hd0,gpt1 or one of the other options then instead of hd0,1
    – SailorCire
    Commented Mar 27, 2015 at 13:07
  • Everytime i type "set root=(hd0,gpt5)" it says nothing. This applies to all other gpt4-1 aswell. The i type in "chainloader +1" and it says "Invalid EFI fle path".
    – David D
    Commented Mar 27, 2015 at 13:15
  • If it helps: i can go to the BIOS(Or UEFI?) and change the boot order. Secure boot is turned off. Windows boot manager is on first place. I should be able to change something there, right?
    – David D
    Commented Mar 27, 2015 at 13:22
  • @don_crissti So it sounds like a USB device and chainload from there; however, I'm not familiar enough with EFI. Do you think you can provide some better explanation?
    – SailorCire
    Commented Mar 27, 2015 at 13:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .