2

What worked for other packages, doesn't work for kernel. Why?

First, sync:

[git@dioptase SRPMS]$ ssh root@localhost yum-builddep /home/git/rpmbuild/SRPMS/kernel-2.6.32-431.el6.src.rpm
Getting requirements for kernel-2.6.32-431.el6.src
 --> Already installed : module-init-tools-3.9-21.el6_4.x86_64
 --> Already installed : patch-2.6-6.el6.x86_64
 --> Already installed : bash-4.1.2-15.el6_4.x86_64
 --> Already installed : coreutils-8.4-31.el6.x86_64
 --> Already installed : 2:tar-1.23-11.el6.x86_64
 --> Already installed : bzip2-1.0.5-7.el6_0.x86_64
 --> Already installed : 1:findutils-4.4.2-6.el6.x86_64
 --> Already installed : gzip-1.3.12-19.el6_4.x86_64
 --> Already installed : m4-1.4.13-5.el6.x86_64
 --> Already installed : 4:perl-5.10.1-136.el6.x86_64
 --> Already installed : 1:make-3.81-20.el6.x86_64
 --> Already installed : diffutils-2.8.1-28.el6.x86_64
 --> Already installed : gawk-3.1.7-10.el6.x86_64
 --> Already installed : gcc-4.4.7-4.el6.x86_64
 --> Already installed : binutils-2.20.51.0.2-5.36.el6.x86_64
 --> Already installed : redhat-rpm-config-9.0.3-42.el6.noarch
 --> Already installed : net-tools-1.60-110.el6_2.x86_64
 --> Already installed : patchutils-0.3.1-3.1.el6.x86_64
 --> Already installed : rpm-build-4.8.0-37.el6.x86_64
 --> Already installed : xmlto-0.0.23-3.el6.x86_64
 --> Already installed : asciidoc-8.4.5-4.1.el6.noarch
 --> Already installed : gnupg2-2.0.14-6.el6_4.x86_64
 --> Already installed : python-2.6.6-51.el6.x86_64
 --> Already installed : hmaccalc-0.9.12-1.el6.x86_64
No uninstalled build requires

Then build:

[git@dioptase SRPMS]$ rpmbuild --rebuild kernel-2.6.32-431.el6.src.rpm
Installing kernel-2.6.32-431.el6.src.rpm
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
error: Failed build dependencies:
        elfutils-libelf-devel is needed by kernel-2.6.32-431.el6.x86_64
        elfutils-devel is needed by kernel-2.6.32-431.el6.x86_64
        binutils-devel is needed by kernel-2.6.32-431.el6.x86_64
        newt-devel is needed by kernel-2.6.32-431.el6.x86_64
        python-devel is needed by kernel-2.6.32-431.el6.x86_64
        audit-libs-devel is needed by kernel-2.6.32-431.el6.x86_64
1
  • mock solves such problems – basin Apr 28 '15 at 15:04
1

Because they are arch dependent. Either rebuild the .src.rpm on the arch. you care about (the one in the source repos. is built on a random supported arch), or download and unpuck the .src.rpm and yum-buildep on the kernel.spec.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.