3

I'm trying to put Ubuntu on my desktop. Right now, it and my laptop are running Manjaro 3.18. I've been using Unetbootin to create the live USB on my laptop. I've tried several different versions of Ubuntu, as well as a couple other distros. I've removed and reinstalled Unetbootin a few times as well. I've reformatted the USB drive each time between tries (FAT32 normally, but I tried ext4 once just to see if anything different would happen). I've used this USB drive many times before for this same purpose. No matter what I try, I get the error:

Failed to load ldlinux.c32
Boot Failed: Press a key to retry...

If there's any other information that would help, let me know.

  • Does the USB stick work to boot a different machine? Curious if it might be something weird about the machine. – derobert Mar 27 '15 at 12:36
  • @derobert It doesn't work with my desktop or my laptop, both which have worked in the past. The only similarity is that they're both running Manjaro right now, but I don't see how that would affect this. – Jacob Jones Mar 27 '15 at 19:03
2

Just came across the same problem. I thought I would share what worked for me for future visitors.

Turns out I had an outdated version of the Rufus software used to create the bootable drive.

I updated the software and that solved the problem.

1

I was able to get this to work by creating the live USB from a different computer. It seems that there is something wrong with the way Unetbootin runs on Manjaro, as even uninstalling and re-installing Unetbootin didn't do the trick (including its dependencies). In my case, I just had to create the live USB with Unetbootin on Windows 7.

0

I faced the same issue when trying to install Fedora 22 from a USB loaded with the DVD image. It turns out the DVD image was corrupted. I downloaded a second image and diff showed that the two images were different. Indeed, I was able to boot from the second image with no problem.

  • I tried 6 or 7 different images. That wasn't the problem. – Jacob Jones May 30 '15 at 20:48
  • @JacobJones, my answer is more towards future visitors to this question than to you (it's gotten 1000 views in 2 months). – drs May 30 '15 at 20:58
  • I have the same problem with Fedora-KDE-Live-x86_64-25-1.3.iso on a DELL Precision T1700, and the ISO checksum checks out, so that's not it. I got it to work by reducing the size of the first partition on the USB stick from the (maximally) 7.4GiB to 6GiB with fdisk, (for some reason, the large partition starts at sector 8192, the small one at sector 2048), then running livecd-iso-to-disk --reset-mbr Fedora-KDE-Live-x86_64-25-1.3.iso /dev/sdX1. This makes it work, but why. – David Tonhofer Jun 12 '17 at 13:20
0

Your bios is the problem not usb .I have a 32GB usb it work on any pentium 4 pc but when I use it on old pc it gives me random errors and this error is one of them I make my usb boot able from sardu boot and I found another answer from SuperUser QA site.

0

I had the same issue turns out it was the flash drive I was using . Was able to try on another flash drive and everything worked fine.Hope it helps.

  • 1
    Welcome to U&L. This message doesn't provide an answer to the question. Please post advices in Comments section bellow the question. – Yurij Goncharuk Apr 4 '18 at 16:08
  • 1
    This might be a useful answer, but I don't know what a "fake usb flash drive" is – Michael Mrozek Apr 4 '18 at 18:08
  • @YurijGoncharuk noted will check on that – StackEdd Apr 5 '18 at 7:48
-1

I had exactly the same issue because of the iso using older Ubuntu mount. Rufus was able to detect and update it and now the iso in the usb is working fine. I am pretty sure this can fix your issue.

  • MY problem was already fixed over 2 years ago. You should give more details to help future users benefit from your answer. – Jacob Jones Aug 10 '17 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.