0

I hope you are well!

I use Manjaro x64_86, using GRUB2 and EFI.

I made a large error after coming home from a night shift. I accidentally removed my boot partition when attempting to format an external hard drive for my girlfriend. I followed instructions from the Manjaro wiki to reinstall grub.

Some steps are confusing, specifically at the start it asks you to mount your boot partition to /mnt/boot:

mount /dev/sda1 /mnt/boot

Then later in the EFI section, it asks you to mount the boot partition to /boot/efi:

sudo mount /dev/sda1 /boot/efi

I wonder if this has contributed.

I happily updated grub using update-grub, without any major hitches:

sudo update-grub

Unfortunately whenever I need to update grub, it does not work. It appears that my computer is using /boot/efi/grub/grub.cfg rather than the /boot/grub/grub.cfg that is automatically updated when I update my kernel/run the update-grub command from inside my currently running Manjaro install.

I have attempted to read through various wikis about GRUB2 and EFI, but each one is asking me to read more and more information. Is there any chance I can change this so it updates automatically again? I promise I'll never use gparted when I'm tired again! :)

Thank you in advance.

EDIT: Specifically my problem now is that when I use sudo update-grub, it only changes

/boot/efi/grub/grub.cfg

and when I turn on my pc and grub loads, it appears to be using

/boot/grub/grub.cfg

instead, which isn't being updated.

  • Between your mount /dev/sda1 /mnt/boot and the mount /dev/sda1/boot/efi is the requirement to chroot (this temporarily moves the top of your directory hierarchy (i.e. /) to the /mnt directory). You didn't mention this vital step; did you miss it? – roaima Mar 25 '15 at 0:16
  • Sorry, I didn't mention it, but I religiously followed the steps. My problem now is that when I use sudo update-grub, it only changes /boot/efi/grub/grub.conf and when I turn on my pc and grub loads, it appears to be using /boot/grub/grub.conf instead, which isn't being updated. – Andrew Mar 25 '15 at 7:11
0

I have done some more reading and I have found the way to update my grub.conf in a different directory. I have not checked if this will now allow it to update automatically in the future, but at least I have a working solution.

My problem was GRUB2 was using

/boot/efi/grub/grub.cfg

and running the script

update-grub

was only updating

/boot/grub/grub.cfg

So I simply ran:

sudo grub-mkconfig -o /boot/efi/grub/grub.cfg

and GRUB2 now loads the additional kernels I had installed.

However, I have not made this work automatically. I think I will see if it is functioning later, if it is not, I will sym-link

/boot/efi/grub/

to

/boot/grub

I have not tested this further solution, so caution is advised.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.