6

I have an old server application that requires libssl.so.0.9.6 and libcrypto.so.0.9.6.

My issue is I currently have libssl.so.1.0.0a and libcrypto.so.1.0.0a on my system. I tried symlinking to the new libraries and it gets me past the error when starting the server application however once the application receives a new connection it immediately crashes. However, it does not give any error about why. I also tried extracting these libraries from an old RPM and placed them in the correct location on the linux server and I would get the same issue.

I have disabled SELinux and disabled iptables. I have the ports forwarded correctly, however this issue keeps persisting. On another linux server I am running an old CentOS release with the openssl version required and it runs without issue.

I think I have narrowed it down to an issue with the openssl version. Does anyone have any idea why this may be happening or if openssl is backward-compatible to such an old version.

  • What distro / version are you using? – Caleb Aug 23 '11 at 8:23
3

No, OpenSSL is not backwards compatible and as you noticed force-feeding libraries that are not the right versions will just make your software die.

Getting the correct expected library versions in place is the right track. You should check with your distribution to see if they have compatibility packages. Some distros have the latest OpenSSL packages, but they also have add-on packages with older libraries to satisfy specific dependencies on older libraries.

2

There are some binary incompatible changes exist between 0.9.6 and 1.0.0 versions of OpenSSL according to the compatibility table.

enter image description here

...

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.