19

I'm running Laptop with single OS: UbuntuMATE 15.04 Beta1 64bit on Toshiba laptop Core i3. After burning "Elementary OS" on a live USB drive using UNetbootin, what happened is:

-After reboot, laptop directly shows UbuntuMATE boot screen, doesn't show Toshiba logo at the begginning as usual. So no access to BIOS or boot menu anymore. So it boots directly to UbuntuMATE and it runs normally.

  • Installed Boot-Repair and ran (Recommended Repair); it gets aborted showing me this message: "Please use this software in a live-session (live-CD or live-USB). This will enable this feature"... which I can't boot from a live CD or USB as I lost access to boot menu.

  • Boot info summary gave me this link http://paste.ubuntu.com/10664795/ which I can ask for help providing information in it.

  • I looked around into several posts but couldn't find what matches my case.

What exactly am I supposed to do? I'm a little new to Linux (3 months) and I'm still learning, so I do not know much.

1
  • Try pressing repeatedly the same keys you used to use for BIOS settings and boot menu just the same, immediately after pressing the power button. You must have disabled the Boot splash screen somehow.
    – To Do
    Oct 2, 2015 at 7:44

5 Answers 5

23

It sounds like you enabled the "fast boot" option in your BIOS setup which disables the F2 setup and F12 boot menu prompts.

Power-off your laptop and hold down the F2 key, then power it on for the BIOS setup utility. Disable "fast boot", save and reboot.

3
  • 4
    still can't access BIOS with holding f2.
    – Ahmed Eid
    Sep 24, 2018 at 9:23
  • 1. Powered-on : hold-on F2 and force power off with the power button 2. Powered-off : power-on with the power button and hold the ESC key
    – tomsihap
    Dec 28, 2020 at 10:05
  • Was freezing up somewhere in the boot process and keyboard events were not registering. My issue ended up being Xorg freezing when loading a legacy Nvidia driver with fast boot turned on in BIOS. Neither method above worked for me after trying a frustrating number of times and with variations. I ended up having to shut down, and unhook my boot (and only) SSD. Leaving it disconnected, was able to hit the bios menu and turn quick boot off and then power off again to reconnect the drive and all is as should be. Sep 27, 2021 at 12:29
15

If your OS uses systemctl, you can bypass "fast boot" via the command line:

sudo systemctl reboot --firmware-setup

This should reboot you directly into the BIOS setup menu.

2
  • 2
    this should be the accepted answer
    – taiyodayo
    Nov 17, 2021 at 3:49
  • 1
    this is best answer
    – Yiffany
    Aug 18, 2023 at 11:10
2

Updating grub timeout to 10 and then rebooting while hitting the delete key did the trick for me.

1

First, try to run update-grub (as root)

If that does not work - try:

gksudo gedit /etc/default/grub

should show something like:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10

You can change GRUB_TIMEOUT=10 to however long you want grub to show up. Then, save the file and run update-grub again

1
  • 3
    His problem is with accessing BIOS and boot menu, not with Grub.
    – To Do
    Oct 2, 2015 at 7:42
1

I've encountered the same problem after installing Manjaro in my laptop Acer Aspire.

If you still cannot access the BIOS/UEFI after disabling fastboot, you can update the BIOS/UEFI with the latest version which is what I did and now I can access the BIOS/UEFI again with F2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .