2

I created infrared receiver as in LIRC manual (http://www.lirc.org/receivers.html). And tested it on windows using program called Terminal.

When I switched on RTS pin DCD pin was also switched on and when I used remote controll DCD was blinking. So everything works with hardware.

Next I tried using the same hardware on Linux Mint 17 on same computer as in http://lifehacker.com/5527752/control-your-desktop-pc-with-a-remote-using-lirc but with no luck:

piotrek-H87-HD3 piotrek # cat /dev/ttyS0 
cat: /dev/ttyS0: Input/output error

I also followed http://www.commandlinefu.com/commands/view/10218/ttys0-terminal-on-serial-connection. In this tutorial there was the same error I had so I tried looking in BIOS setup but serial ports were enabled.

Why isin't it working?

Some information data:

piotrek-H87-HD3 piotrek # cat /proc/tty/driver/serial
serinfo:1.0 driver revision:
0: uart:16550A port:000003F8 irq:4 tx:0 rx:0
1: uart:unknown port:000002F8 irq:3
2: uart:unknown port:000003E8 irq:4
3: uart:unknown port:000002E8 irq:3
4: uart:16550A port:0000F080 irq:19 tx:34 rx:0 CTS|DSR|CD
5: uart:unknown port:00000000 irq:0
6: uart:unknown port:00000000 irq:0
7: uart:unknown port:00000000 irq:0
8: uart:unknown port:00000000 irq:0
...

//EDIT

I was wondering lately if maybe linux somehow switched pin layout of my serial port? My motherboard COM port pins layout is :

Motherboard layout

I have back panel extension cord which maps 1:1 pin layout from motherboard to back panel like this:

-------------------
\ [1][3][5][7][9] /
 \  [2][4][6][8] /
  \ ___________ /

In windows pin order is same as in motherboard manual. Is it possible that pins are switched somehow? Can I check it?

Nobody seems to know the answer so maybe I ask another question. Can I write some script (python maybe?) that will enable selected pins on /dev/ttyS0 so I could measure voltage and check which pin is which?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.