12

I to mount my ASUS Android device in Linux Mint 17.1 (MTP). My pc didn't see my device, so I tried following the answer in this page: http://forum.xda-developers.com/showthread.php?t=1077377

But when I click on "connect" I get the following error:

Listing raw device(s)
mtpfs: symbol lookup error: mtpfs: undefined symbol: LIBMTP_Detect_Raw_Devices
  • Have you found a solution for this ? – DrkStr Jun 21 '15 at 10:38
11

Linux Mint 17.1 Cinnamon 64-bit or a recent Ubuntu/Debian distribution.

sudo apt-get update
sudo apt-get install mtp-tools

Unplug the USB cable and reconnect your Android device.

The Android device should now be recognised as expected.


If you are still having problems, please try the following.

Check if you have other MTP software installed, run the following in a terminal window:

dpkg --get-selections | grep -v deinstall | grep -i mtp

This will list any packages relating with MTP. You should only need mtp-tools installed for normal, everyday use.

Ignore any lines starting with "libmtp" and uninstall any other packages listed except mtp-tools for example with the following command replacing 'mtp-server' with what you have listed from the previous instruction.

sudo apt-get remove mtp-server

Then reinstall the mtp-tools package with the following command:

sudo apt-get install --reinstall mtp-tools

You should now be able to access your Android device using MTP as expected from a Removable Storage device.

  • 8
    this didn't work for me – BЈовић Oct 16 '15 at 20:57
  • this did work for me (mpt-tools). Phone: Xperia Z3 conneted via cable/mtp, OS: Xubuntu 16.04 – Munchies Aug 17 '16 at 13:10
  • Worked for me. Make sure you are using a data cable not just on for charging, and click accept permission on the phone. – Graham Russell Jan 9 '18 at 9:50
3

Go to Synaptic Package Manager and install mtp-server. I use Linux Mint 17.1 Mate and my cell would not appear on my laptop, but after installing mtp-server it worked.

  • 4
    doesn't work. I installed the packages and rebooted the pc, but pc doesn't see the device. – Alas Mar 28 '15 at 10:18
  • This worked for me – grimurd Feb 10 '16 at 11:27

protected by Anthon Feb 20 '16 at 11:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.