1

I use Debian Jessie (testing) and I have Eclipse 3.8. Newest version of Eclipse is 4.4. In Debian Sid (unstable) I have still Eclipse 3.8.

How can I install newest version of Eclipse on this museum of software? ;)

0

2 Answers 2

2

The first step when installing Eclipse on Debian is to make sure you have openjdk-7-jdk or openjdk-8-jdk installed, and that the default Java is appropriate (update-java-alternatives).

Since Eclipse 4.6 (Neon), there are two ways of installing the system: using an installer (Oomph) or using tarballs.

The Oomph installer

If you want to use the installer, download it from the main Eclipse downloads page, extract it and run it (eclipse-inst in the eclipse-installer folder). This will open the installer window:

Eclipse installer

Notice the exclamation point in the top-right-hand corner: this means there are updates. You should click on the hamburger and update the installer before continuing; the installer will restart.

Once your installer is up-to-date, select the Eclipse product you're interested in:

Installation parameters

Here you can change the target installation folder, choose the version you want, and verify that your JVM is appropriate. Clicking on the big "INSTALL" button will download the appropriate files and install Eclipse.

Product tarballs

If you don't like the installer, or can't use it for some reason, or want to download once and install multiple times, you can still download installation tarballs from the package download page. Once you have a tarball, extract it into a new directory in your home directory, then run it from there.

In both cases you can also install it to /opt if you prefer; just make sure you use a version-specific Eclipse directory (/opt/eclipse-4.6).

5
  • Thanks Stephen! I changed the Installation Folder to ~/eclipse/java-neon but when I try to execute the program, I get the error "The Eclipse executable launcher was unable to locate its companion shared library." I put the Oomph Installer into Advanced Mode and tried to make another Bundle Pool in my user's home directory, but I still can't launch Eclipse as anything but root. How do you deal with this? Do you just run Eclipse as root? To me, this seems like a Really Bad Idea.
    – Matt Obert
    Sep 8, 2016 at 22:09
  • Also, how do I clean up after the Oomph Installer? I have currently installed Eclipse 4.6 Neon under /root/, /opt/, and $HOME. Only the version under /root/ will launch, and even then only as the super-user.
    – Matt Obert
    Sep 9, 2016 at 3:05
  • Hey Stephen, it's me again. I got the tarball and have no problem using it the old way. I realize now that the Oomph installer has some advantages for multi-user installations. I am up and running in my home directory in a ~/dorkspace next to my messed-up ~/workspace and getting work done without stopping to clean up my Oomph messes. If I do want to remove them, should I just barge around and rm -rf * stuff? Or should I post that as a separate question?
    – Matt Obert
    Sep 10, 2016 at 1:51
  • The Oomph installer just works for me (as a standard user), I don't know what could be causing your library errors. Once installed, I run Eclipse as a standard user too, not as root. To clean up after the Oomph installer, just delete its folder (that's where it caches its downloads). Likewise for Eclipse, just delete the folder you installed to. Your settings are in ~/.eclipse (so delete that in /root perhaps). Sep 10, 2016 at 8:30
  • @MattObert I'm also not sure how well Oomph and Eclipse cope with multi-user installations; IIRC the Debian package has patches for this, otherwise updates and extra plugin installations fail (it tries to write to the system-owned, shared Eclipse directories). Sep 10, 2016 at 8:32
0

I think my problem is just that I accepted the default installation directory so my default Bundle Pool was owned by root. Once I finish writing JUnit tests for my classes, I might try to clean up after Oomph. Thanks for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.