1

After I initially setup Debian, I installed CUPS so that I could print. I have a Brother MFC-9120CN, which I setup following the Debian printing instructions. After it was setup, I printed 1 or 2 pages. I hadn't tried to print for while after that, and then one day I tried to print something and it didn't work.

I tried to fix it by deleting the printer and then adding it again, but that didn't work. I have tried various protocols, which didn't work. I also tried scanning with nmap to see if I could find it on the network and see all of the available printing ports. I also tried pinging it, which also worked.

The weirdest part about all of this, is that the printer is for sure getting a signal, because the printer's LCD backlight is coming on when I try to print anything. The CUPS job history even shows that the print jobs "completed".

The only thing that I can think of, is that something changed after cups initially started, because that is the only time I was able to print. I feel like my printer is trolling me. Does anybody know if there might be something that I haven't tried?

Update: I tried reinstalling CUPS. The printer still gets a signal. It will actually start making a warm up sound.You can tell it's about to print, but it doesn't. It's like my printer actually has something personally against Linux. Please help.

  • Does the printer work from another OS? – texasflood Mar 23 '15 at 19:32
  • And you said you could print before, did you try printing the exact same document that you printed before now? – texasflood Mar 23 '15 at 19:33
  • @texasflood You can print to the printer over the network from Windows just fine. I don't know what document I printed, but I have tried printing test pages as well as printing a PNG image (which is probably the same type of file that I printed before). – Lysol Mar 23 '15 at 22:41
  • Any luck with the issue? Seems very similar to my problem. It seems like some internal buffer gets filled or so, so the printer succeeds for smaller documents, but fails for larger ones. – Petr Pudlák Oct 2 '16 at 17:08
  • @PetrPudlák Luck is all that I had. It automagically fixed itself. One thing I would like to mention is that other computers on my network could print to it without problems when I had this issue. – Lysol Oct 5 '16 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.