0

I have a Raspberry Pi 2 with a WiFi USB dongle. I don't know the brand or model, I got it for free with my Xtreamer Mk1 in 2009. My Windows 7 PC installs some generic Realtek RTL8191SU WLAN adapter driver when I plug it in. On the Pi I use OpenELEC 5.0.5 which also has drivers for it.

My network setup

In my living room on the first floor, I have an AVM Fritz!Box 6360 Cable router (802.11bgna). In my office on the third floor, I have an additional access point (Linksys WRT54GL (802.11bg only), but I also tried a TP-Link TL-WA901ND). The Fritz!Box provides a main network and a guest network, both with letter-only SSIDs and secured with WPA2 Personal. The main network's passphrase looks like Hello123+World456=Foobar789 (alphanumeric, plus and equal signs), the guest network's passphrase is all lower-case letters. The access point in the office only provides the main network on a different channel (5 channels distance to the Fritz!Box, channels 3 and 8), with the same security settings, of course. We use the main network mainly with our iPad 2 and our mobile phones (Sony Xperia Z2, Google Nexus 5) which have no problems whatsoever including seemless roaming between the two stations.

My problem

As soon as it works, the Pi is going to be a media player in a room where I can't put an ethernet cable. And since those powerline things have a really bad transmission rate in my case, I chose WiFi. The Pi detects the USB dongle and the OpenELEC setup UI also shows me some networks, including my main and guest networks. When I connect to my main network, the status always becomes associating and then failure. Since OpenELEC uses connman to manage its connections, I looked into connman's config files (via SSH and a wired connection). It says Failure=invalid-key on the last line. But I checked it about 20 times now - the key was correct. When I tried to connect to my guest network, it instantly worked. First I thought it was the passphrase. (Maybe the main network's passphrase was saved incorrectly or something.) I even tried changing the main network's passphrase multiple times. But I found out that the problem was the access point. When I plugged out the AP, the Pi connected to my main network without any problems. Then I thought that the USB dongle may be incompatible with the access point and tried another access point (the TP-Link mentioned above), but the problem was still there. Then I plugged the USB dongle into my Windows PC, and my PC had no problems connecting to the access point (the Linksys again, I had the TP-Link just for a short time).

So apparently, it's just the Pi that won't connect to any of my access points, but perfectly connects to my router. Does anyone have a hint for me how to solve this? Or at least a suggestion what I haven't tried yet? Thanks in advance.

P.S.: If you need more information, just leave a comment.

0

The problem is probably the wireless dongle in your Pi. It is a very basic dongle that comes with it, so try a different dongle and hopefully that should solve the problem.

Kind Regards,

Indraj Gandham

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.