2

I am trying to do an apt-get update and apt-get upgrade on my Debian Wheezy armhf system, but the upgrade is failing with the above error. Networking is working, and my /etc/apt/sources.list is:

deb http://ftp.us.debian.org/debian/ wheezy main contrib non-free

How can I fix this?

1

From your armhf system try to ping the 64.50.236.52 ip address.

ping 64.50.236.52

If you don't have any answer check your internet connection. On the other hand, if you got answer from this ip address ping the ftp server name

ping ftp.us.debian.org

If it doesn't answer, go to your /etc/resolv.conf file and verify it is properly set.

  • The error message gives the IP address, which means DNS is resolving correctly. The configuration file is /etc/resolv.conf, without the final 'e'. – Stephen Kitt Mar 22 '15 at 17:49
  • Yes I can ping that address and connect over http fine. – SeanLabs Mar 22 '15 at 17:53
  • Have you tried apt-get update or have you tried to use a different repo? for instanance "deb ftp.au.debian.org/debian wheezy main contrib non-free" – dgsleeps Mar 22 '15 at 18:03
  • Tried your suggestion, but now am getting "W: Failed to fetch gzip:/var/lib/apt/lists/partial/ftp.au.debian.org_debian_dists_wheezy_contrib_binary-armhf_Packages Hash Sum mismatch" – SeanLabs Mar 22 '15 at 19:39
  • OK I cleaned up some temp. files & ran apt-get update again, now I am getting "W: Failed to fetch ftp.au.debian.org/debian/dists/wheezy/main/binary-armhf/… 406 Not Acceptable" – SeanLabs Mar 22 '15 at 20:27
1

Some systems have trouble accessing IPv6 resources which can effect reaching deb.debian.org for example. Disabling IPv6 has worked for me in the past in resolving the "Unable to connect" issue:

sysctl -w net.ipv6.conf.all.disable_ipv6=1
sysctl -w net.ipv6.conf.default.disable_ipv6=1

( no restart or services required )

0

OK, I modified sources.lst to be this:

deb http://ftp.us.debian.org/debian wheezy main contrib non-free
deb http://security.debian.org wheezy/updates main contrib non-free

then re-ran update and upgrade again and it updated fine this time,.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.