5

I moved from Ubuntu 12.10 to 14.04 and have a Canon Canoscan LiDE 25. It worked fine with Xsane on 12.10.

Now I have the strange effect that I can use the scanner with scanimage all the time, but as soon as I use Xsane or any other frontend, it only produces black images (the scanner does not move at all). Occasionally, I can scan once (mostly preview) and the second attempt produces only black again. I can use scanimage afterwards and it is fine.

Seems to be a kind of reset problem to me, because when Xsane comes up and the scanner makes a short noise, the first scan works. Also when I scan, the scan arm does not return to the start position. Afterwards, it creates black images.

The reset problem occurs with other front-ends as well.

Suggestions welcome. Running the latest 1.0.25 sane version (compiled from source). Also the default install did not work before, hence I tried my luck with latest. Changed the cable too as suggested in other threads, but not change.

  • libsane now: 1.0.25git, Kernel 3.13.0
  • libsane was: 1.0.22, Kernel 3.2.0

Any debug help welcome.

  • Have you tried gscan2pdf? Please specify the libsane version on 12.10, and the versions you are trying to use. Also the corresponding kernels. Using the versions from 12.04 is probably an option, if only as a temporary debugging measure. – Faheem Mitha Mar 22 '15 at 13:01
  • gscan2pdf shows the same behavior. It is not the sane version I think because scanimage works fine. So it must be the usage of sane somehow. – René Schwietzke Mar 22 '15 at 15:48
  • Note: backporting in such cases is generally an option, and preferable to installing from source. Note: my earlier suggestion was to forwardport everything from 12.10 and see if that solved the problem. I think sane is reasonably self-contained, so that is probably doable. – Faheem Mitha Mar 22 '15 at 15:51
  • Got closer. Disabling USB autosuspend seems to be the solution. – René Schwietzke Mar 22 '15 at 15:56
4

Ok. Solved the mystery myself. It is related to USB autosuspend. It seems to kick in too early and the UIs do not wakeup the device properly, only scanimage does it.

I use TLP to control powersaving settings. So I got the device id using lsusb and added it to the USB_BLACKLIST line. Works as expected right now.

Took my 10 hours to figure it out, because similar cases had always some different reasons or stayed unanswered.

  • What is this tlp? – Faheem Mitha Mar 22 '15 at 16:13
  • 1
    TLP brings you the benefits of advanced power management for Linux without the need to understand every technical detail. TLP comes with a default configuration already optimized for battery life, so you may just install and forget it. Nevertheless TLP is highly customizable to fulfil your specific requirements. linrunner.de/en/tlp/tlp.html – René Schwietzke Mar 22 '15 at 16:14
  • 1
    This was cross-posted on askubuntu.com at askubuntu.com/questions/599694/…. Please mention that as you go. – Cbhihe Jun 21 '15 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.