3

This question already has an answer here:

Lest say I mount a usb drive to /mnt and next I run this...

mount --bind /mnt /tmp/test.d

It's a successful bind, but now when I run lsblk only the bind point shows.

How can I get all bound and original mount points listed?

When I use findmnt, it shows both, but it doesn't tell me which one is the original mount point. How can I learn this?

marked as duplicate by Gilles, Ramesh, cuonglm, terdon Apr 25 '15 at 19:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    why not using mount or better findmnt? – taliezin Mar 21 '15 at 16:00
  • Thats good info. How can I find which is the original mount point? Both show up and have the same information other than mount directory. – Michael Bruce Mar 21 '15 at 16:23
  • 1
    Yeah, findmnt -R /path/to/mount/point/dir will make it very clear w/ defaulys. – mikeserv Mar 21 '15 at 17:08
  • Using device instead of directory worked for me. findmnt -r /dev/sdb1 this listed all mount and binds :) – Michael Bruce Mar 21 '15 at 17:57
  • 1
    IIRC this information is not kept anywhere: after mount --bind, the two copies are equivalent, there isn't one that's more “original” than the other. After all there could be no original if you'd already unmounted /mnt. – Gilles Mar 21 '15 at 18:49

Browse other questions tagged or ask your own question.