0

On my dell laptop vga is

Intel Corporation Haswell-ULT Integrated Graphics

I have downloaded and installed on slackware 14.1 libvdpau-gl,vdpau-intel-driver,and of course libva. Mplayer works fine,xine is ultraslow,give me this error

"vdp_status_no_implementation"

and video is fast like a 3d game with 3d disabled. I see vaapi option is missing on xine,why?

I tried to add manually vaapi on xine/config give me this error

libva info: VA-API version 0.34.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/va/drivers/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_34
libva info: va_openDriver() returns 0
vo_vdpau: vdpau API version : 1
vo_vdpau: vdpau implementation description : OpenGL/VAAPI/libswscale backend for VDPAU
vo_vdpau: maximum video surface size for chroma type 4:2:2 is 1920x1080
vo_vdpau: maximum video surface size for chroma type 4:2:0 is 1920x1080
vo_vdpau: maximum output surface size is 8192x8192
vo_vdpau: Failed to check vdpau get/put bits native capability : VDP_STATUS_NO_IMPLEMENTATION

I try to recompile but won't compile vaapi,i have installed latest vaapi now

  • What's the value of video.driver in ~/.xine/config? Is it set to vaapi? – Stephen Kitt Mar 20 '15 at 19:22
  • vaapi is missing,i try to set manually – elbarna Mar 20 '15 at 19:23
  • What version of Xine do you have? – Stephen Kitt Mar 20 '15 at 19:25
  • Latest xine lib 1.2.6 – elbarna Mar 20 '15 at 19:26
  • What about the other packages involved? In particular, __vaDriverInit_0_34 indicates you're not running the latest libva... – Stephen Kitt Mar 20 '15 at 19:32
0

Solution found,i had to navigate into Xine settings and use vdpau or auto.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.