2

I am trying to connect to wifi using wpa_supplicant. I use this config:

network={
ssid="guest"
#psk="guest"
psk=<numbers>
}

I also tried this config:

update_config=1
network={
        ssid="Guest"
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP TKIP
        group=CCMP TKIP
        psk=<numbers>
        }

I run this command:

wpa_supplicant  -iwlan0 -c/etc/wpa_supplicant.conf

And it appears to connect and auth:

rfkill: Cannot open RFKILL control device
ioctl[SIOCSIWAP]: Operation not permitted
wlan0: Trying to associate with e8:04:62:23:57:d0 (SSID='Guest' freq=2412 MHz)
wlan0: Associated with e8:04:62:23:57:d0
wlan0: WPA: Key negotiation completed with e8:04:62:23:57:d0 [PTK=CCMP GTK=CCMP]
wlan0: CTRL-EVENT-CONNECTED - Connection to e8:04:62:23:57:d0 completed (auth) [id=0 id_str=]

I try to get an address via dhcp and it appears to work from the messages, however there is no IP address assigned to wlan0 and I have no internet access as a result.

[root@switch /]# dhclient -v wlan0                                              
Internet Systems Consortium DHCP Client 4.1.1-P1                                
Copyright 2004-2010 Internet Systems Consortium.                                
All rights reserved.                                                            
For info, please visit https://www.isc.org/software/dhcp/                       

Listening on LPF/wlan0/74:da:38:0a:38:3d                                        
Sending on   LPF/wlan0/74:da:38:0a:38:3d                                        
Sending on   Socket/fallback                                                    
DHCPREQUEST on wlan0 to 255.255.255.255 port 67                                 
DHCPACK from 10.10.100.1                                                        
bound to 10.10.100.180 -- renewal in 2912 seconds. 

Any ideas why the wlan0 does not get an address?

EDIT: I see syslog has this message but not sure what it means

rtw_wx_set_mlme, cmd=0, reason=3    

EDIT:

If I statically assign the leased address and add a default gateway manually it works. But only if I add the leased address.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.