1

I'm running squid on a server and, sometimes, the log gets flooded with messages caused by a specific host (192.168.1.20). These message I'm refering to is (some.website.com is not the actual website, it's just an example):

...

192.168.1.20 TCP_MISS/404 0 CONNECT some.website.com:443 - DIRECT/- -

...

In an attempt to stop these messages I added the following in squid.conf but the log kept being flooded with the same message:

acl disable-website dstdomain .website.com
cache deny disable-website

What am I doing wrong?

  • Some reason you don't just fix 192.168.1.20? – derobert Mar 18 '15 at 18:04
2

cache deny asks Squid not to keep a cache of the matched URLs, but not to prevent users from accessing them; what you want here is http_access deny disable-website.

  • Thanks for the reply. I'll try that. Soon I'll tell you if it worked :) – bulvgo Mar 18 '15 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.