3

I have big problem on my Debian 6 server. I can't install/uninstall any packages on my system. When I try install something I see this error:

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 consolekit : Depends: libglib2.0-0 (>= 2.37.3) but 2.24.2-1 is to be installed
              Breaks: udev (< 204-1) but 164-3 is to be installed
 libgudev-1.0-0 : Depends: libglib2.0-0 (>= 2.37.3) but 2.24.2-1 is to be installed
 libpolkit-agent-1-0 : Depends: libglib2.0-0 (>= 2.37.3) but 2.24.2-1 is to be installed
                       Depends: libpolkit-gobject-1-0 (>= 0.105) but 0.96-4+squeeze2 is to be installed
 libsecret-1-0 : Depends: libglib2.0-0 (>= 2.38.0) but 2.24.2-1 is to be installed
 libudisks2-0 : Depends: libglib2.0-0 (>= 2.37.3) but 2.24.2-1 is to be installed
 policycoreutils : Depends: libaudit0 but it is not going to be installed
 xserver-xorg-input-all : Depends: xserver-xorg-input-vmmouse but it is not going to be installed
                          Recommends: xserver-xorg-input-wacom but it is not going to be installed
 xserver-xorg-input-evdev : Depends: libevdev2 (>= 0.9.1) but it is not going to be installed
                            Depends: libmtdev1 (>= 1.1.0) but it is not going to be installed
 xserver-xorg-input-synaptics : Depends: libevdev2 (>= 1.3) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

When I try apt-get -f install:

dpkg: considering deconfiguration of sysvinit-utils, which would be broken by installation of startpar ...
dpkg: no, sysvinit-utils is essential, will not deconfigure
 it in order to enable installation of startpar
dpkg: error processing archive /var/cache/apt/archives/startpar_0.59-3_amd64.deb (--unpack):
 installing startpar would break existing software
configured to not write apport reports

Errors were encountered while processing:
 /var/cache/apt/archives/startpar_0.59-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

/etc/apt/sources.list contains:

deb http://ftp.pl.debian.org/debian/ squeeze main
deb-src http://ftp.pl.debian.org/debian/ squeeze main
deb http://http.debian.net/debian/ squeeze-lts main contrib non-free
deb-src http://http.debian.net/debian/ squeeze-lts main contrib non-free
deb http://http.debian.net/debian/ squeeze main contrib non-free
deb-src http://http.debian.net/debian/ squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main
deb http://debian.sur5r.net/i3/ squeeze universe
deb http://ftp.debian.org/debian sid main
  • Try commenting out the last line (add # at the start of the line), the one containing sid; then apt-get update and try apt-get -f install. – Stephen Kitt Mar 18 '15 at 14:25
  • Have you tried sudo dpkg --configure -a? – Pandya Mar 18 '15 at 14:49
1

The errors stem from the fact that your apt configuration mixes Squeeze (Debian 6) and Sid (Debian unstable). This is a bad idea...

You need to drop sid from your /etc/apt/sources.list file (comment the line with #), then run

apt-get update
apt-get -f install

to fix things.

4

I was getting this error:

dpkg: considering deconfiguration of sysvinit-utils, which would 
      be broken by installation of startpar ...
dpkg: no, sysvinit-utils is essential, will not deconfigure
      it in order to enable installation of startpar
dpkg: error processing archive 
   /var/cache/apt/archives/startpar_0.59-3_amd64.deb (--unpack):
installing startpar would break existing software

This is how I fixed it:

dpkg --auto-deconfigure --force-remove-essential -i   \
             /var/cache/apt/archives/startpar_0.59-3_amd64.deb \
             /var/cache/apt/archives/sysvinit-utils_2.88dsf-59_amd64.deb 

The upgrade I was doing then continued on fine.

  • This was very helpful for me when i updated an old NAS running Wheezy to Jessie today. – Matthias Oct 20 '17 at 19:08
2

Squeeze has been deprecated , You have to do :

sed -i 's/squeeze/wheezy/g' /etc/apt/sources.list
apt-get update
apt-get -f dist-upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.