0

I have this problem:
I have a laptop with WiFi and eth.

The WiFi is connected to the internet and has the following config:
192.168.1.100 and 192.168.1.1 as gateway

The eth is connected in this way and it does not have access to internet:
192.168.0.100 and 192.168.0.254 as gateway

How can I make that internet works correctly and when I go to 192.168.0.254 it connects to the subnet?

PS: I use NetworkManger, but in case I can use Wicd.
The OS is ArchLinux.

  • 1
    in network concept, YOU CANT TWO DEFAULT GW CUNCURRECNTLY.... – PersianGulf Mar 17 '15 at 21:00
  • Thats simple. You don't need a gateway on your eth interface. You are the gateway to the net you are member, talking on a very very simple way. You just need the wifi gateway, and you are good to go. If you take a look at your routes, you will have something like 192.168.1.0/24 dev wlan1 proto kernel scope link src 192.168.1.22 metric 9 that translates to - "To access all the /24 subnet, use ME(my ip address) as the source of this route" – user34720 Mar 17 '15 at 21:05
  • You can definitely have two default gateways on a system you just have to do policy-based routing to specify which gateway gets selected when. This may or may not play well with NetworkManager you may have to try it to see. – Bratchley Mar 17 '15 at 21:35
  • If I'm understanding above you would specify the default gateway in your main routing table as being the internet gateway, but do the ip route add table 2 and ip rule commands for the 192.168.0.254 address. – Bratchley Mar 17 '15 at 21:37
  • 1
    Ok, maybe I've found a solution (I need to test it further though...) Just check in the IPv4 tab the option "Use this connection only for resources on its network". In this way NetworkManager doesn't create an additional default gw and internet works correctly... :P – TesX Mar 19 '15 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.