1

I recently installed gstreamer-ffmpeg-0.10.i686 on RHEL 7. As a result of this text in my java program has become slightly larger (maybe 2 or 3 font sizes), which is enough to mess with some of the UI elements. My guess is that gstreamer-ffmpeg or one of its dependencies is adjusting global font settings.

I tried doing a "yum history undo #" to revert back to before gstreamer-ffmpeg, but a few font changes persist (though not all).

gstreamer itself is already installed.

The culprit I assumed was the dependency: fontconfigs, but I unpacked the rpm and diff'ed the files inside with the originals (I have another image of this machine) and saw no changes, I've been looking through the file contents of each dependency, but I'm not seeing why these changes exist.

I also tried a "find /etc/ -mtime -1", but all of the files either seem unrelated to fonts or are the same as before. I tried the same on /var and /usr with the same results.

Most notably /etc/X11/xorg.conf is the same, including the fontpath value, though based on the modified time it was touched in some way by the installation.

I am looking to make use of gstreamer-ffmpeg, but I also want to change the fonts on my java app back the way it was previously, I'm assuming that gstreamer-ffmpeg or a dependency changes something somewhere, but I can't seem to find where.

1

This was a result of one of its dependencies: font-config, which sets the default font for many things.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.