I'm trying to run a Linaro Beagleboard image under Qemu and I have trouble with the keyboard and mouse. Basically neither the keyboard nor the mouse work once the boot process completes. I tried two types of images, one with a full Ubuntu desktop and the other with just a minimal filesystem. Both of them boot OK but then I cannot interact in any way with the virtualized system; for the minimal image I get to the login prompt, it auto-logins as root but then I cannot do anything(it's very, very frustrating). I've tried starting both from the command line and from Qemulator GUI but with the same outcome. What could be the problem? The Qemu command line follows:

qemu-system-arm -M beaglexm -m 256 -sd /home/mac/work/qemu_images/beagle-nano.img 
-k en-us -append "console=ttyS0" -serial stdio -usb 
-hda /home/mac/work/qemu_images/beagle-nano.img 
-localtime -net nic,vlan=1 -net user,vlan=1,hostname=beagle_nano 
-kernel /home/mac/work/qemu_images/vmlinuz-3.0.0-1002-linaro-omap 
-initrd /home/mac/work/qemu_images/initrd.img-3.0.0-1002-linaro-omap

I also tried without the direct boot which uses the kernel and the initial ramdisk images, but still no luck.


After looking a bit through the Linaro wiki, especially this page I decided to download the source package for Linaro version of Qemu, which apparently has a lot of enhancements for ARM that did not make it into the upstream Qemu available for Ubuntu Natty, and build it myself. It works like a charm with the Beagleboard image provided also by Linaro(I haven't done extensive testing but it boots and the keyboard works)! So just download the latest(August) source packages from here, unpack it and then ./configure --perfix=/usr; make; make install(the --prefix=/usr is required if there is already a Qemu installed on the machine). The build process should proceed without any problems(for me it did). The Qemu(Linaro version) full command line follows:

qemu-system-arm -M beaglexm -m 256 -sd /home/mac/work/qemu_images/beagle-nano.img 
-k en-us -append "console=ttyS0,115200n8" -serial stdio 
-device usb-kbd -device usb-mouse -usb -hda 
/home/mac/work/qemu_images/beagle-nano.img -localtime -net nic,vlan=1 
-net user,vlan=1,hostname=beagle_nano  
-kernel /home/mac/work/qemu_images/vmlinuz-3.0.0-1002-linaro-omap 
-initrd /home/mac/work/qemu_images/initrd.img-3.0.0-1002-linaro-omap

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.