4

While booting the installation program (via USB), the screen goes black, it looks just like the screen has been switched off.

The laptop is a Lenovo Ideapad z475 and, as per the "Beginners' Guide", I've tried to use i915.modeset=0 and video=SVIDEO-1:d, still the same black screen however.

The graphics card is AMD(ATI) AMD Radeon HD 6470M & HD 6520G

The installation media is archlinux-2011.08.19-netinstall-x86_64"/"archlinux-2011.08.19-core-x86_64

  • What is your capability? Archlinux is one of the most difficult distros to install. You are looking at the Beginners' Guide but you are reading it incorrectly."If using an Intel video chipset" use "i915.modeset=0 Alternatively, add: video=SVIDEO-1:d" BUT you don't have an Intel video chipset. You need to be looking at: wiki.archlinux.org/index.php/… – user8779 Aug 20 '11 at 9:08
  • @Caleb: sorry, won't do that again. :) – Eric Aug 20 '11 at 15:13
7

If Kernel Mode Setting (KMS) is inhibiting your graphics card from working properly, you can disable it by appending radeon.modeset=0 to the grub line.

If that fails, try a simple nomodeset.

For more information about running an ATI card under Arch, see the ATI page on the Arch wiki.

  • This also worked for me on Arch linux with an NVIDIA card. My problem was I could not install Arch because I always got black screen booting the installation, "nomodeset" fixed this :) – pedronveloso Jan 21 '15 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.