I just installed puppy linux but the screen is literally burning my eyes. The Fn+Brightness key on my laptp doesn't work. I tried to go to setup and change the gamma but it just make the colors darker, the screen itself keeps being extremly bright so I think it's due to the backlight.

How can I diminish the backlight or the thing that keeps the screen bright despite me lowering gamma ?

Edit: in fact when I'm in command prompt mode (GUI closed) the screen is still very bright. Is there a way to fix that too ?

Edit: I managed to add acpi_backlight=vendor in GRUB as you can find on the internet to fix this problem but this doesn't change anything. Pressing Fn+Arrow still doesn't work and changing the brightness file in acpi_video doesn't work either.

6 Answers 6


Try this. See if /sys/class/backlight/acpi_video0/ exists. If it does

cat /sys/class/backlight/acpi_video0/max_brightness

gives the max allowed brightness, and you can set brightness thus (where X is a value 0-'max_brightness'):

echo X >/sys/class/backlight/acpi_video0/brightness
  • Unfortunately this doesn't work, I change brightness to 2 (max brightness = 7), restart the GUI but it doesn't change anything
    – Wicelo
    Mar 16, 2015 at 12:56
  • did the value you set definitely take? you could try this as alternative: tee /sys/class/backlight/acpi_video0/brightness <<< 2. Have a look at more suggestions here.
    – gogoud
    Mar 16, 2015 at 13:10
  • well when I restart GUI actual_brightness is set to 2
    – Wicelo
    Mar 16, 2015 at 13:29
  • in fact it's not only the GUI but also the screen while in command prompt mode too.
    – Wicelo
    Mar 16, 2015 at 13:35
  • 1
    oh dear. I think a solution, if there is one, will be quite hardware-specific, prob good idea to add details of your hardware (i.e. exact laptop model) in the question.
    – gogoud
    Mar 16, 2015 at 13:59

Have just tried echo X >/sys/class/backlight/acpi_video0/brightness on my HP 6450b with Puppy 5.7.1 and it does the job fine.


my speculation success, i use "echo 200 >/sys/class/backlight/intel_backlight/brightness" where my max brightness on intel_backlight is 976. ACER 4741 Intel Display

echo 300 >/sys/class/backlight/intel_backlight/brightness 

works for IGPs (Integrated Graphic Processors), like Intel chips.

echo X >/sys/class/backlight/acpi_video0/brightness

probably for external graphics cards.


Go to Menu > Desktop > Redshift

There is a Screen Brightness Setting.


on slacko or puppy linux use the tool gamma calibration tool in setup for screen -100 +100

setup/puppy setup / graphics screen open monitor gamma calibration

i had to do this when using a tv as a monitor to soften the brightness

but now got it just right , only probelm i had is the screen resolution with using a tv had to settle for 1040

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.