1

After using airmon-ng in kali linux the list of available networks is missing in the menu bar at the top. Can anyone please tell me how to "reactivate" it?

When i use iwconfig it shows up an entry for wlan0

Mode: changed
Access point: not associated
RTS thr: off
Fragment thr: off
enc key: off
power management: off

lo -> no wireless connection
eth0 -> no wireless connection
3

You need to end the monitor mode you created.

sudo airmon-ng stop mon0

I would also assume that you killed any processes that airmon complained about upon starting your monitor interface. So you need to restart network manager and any other processes you killed.

sudo service network-manager start

as well as starting any other services you stopped or running any other commands that you killed after your airmon-ng start command.

EDIT: A good old restart usually does the trick if you cant remember everything you did.

  • Sorry, maybe you must know i run kali from a pendrive and of course a restart did the job but i thought maybe there is a smoother way than doing so. i already tried stopping mon mode but got a input/output error every time i tried. i tried service network-manager start now but got the same i/o error. now. – BrainWorx Mar 16 '15 at 0:10
  • What is the error its giving you? I would assume this is the root cause of your problem – Dylan Mar 16 '15 at 0:11
  • the error at which point? after using airmon mode and quitting it, the symbol for network connections at the top menu is not visible anymore and i try to bring it back. i also couldnt start other processes and so i thought maybe its an "error" from my kali installation because i burnt it on a pen drive. – BrainWorx Mar 16 '15 at 0:16
  • What is the input/output error you get when you try to stop monitor mode and when you try to restart network-manager? – Dylan Mar 16 '15 at 0:17
  • at that point is no error when i type airmon-ng stop mon0 i get a list of interfaces including only wlan0 (mon mode off). then, when i type in service network-manager start i get the error message: unable to execute /usr/sbin/service: Input/Output error – BrainWorx Mar 16 '15 at 0:19
0

If you are using Kali Linux just type NetworkManager, this command will bring the interface back.

-1

I fixed it by typing:

/etc/init.d/network-manager force-reload

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.