1

I am having trouble getting my Debian server to change the address where it requests its IP address.

I currently have two routers.

My primary distributes IP addresses to various machines on the network (PS3, cell phones, computers wirelessly/corded) All these devices work with no problems. I have verified all of the ports on my router by disconnected the devices that work (PS3 and some computers), connecting them to different ports, and confirming that they connect to the Internet.

My secondary router is for learning purposes and I connect it to the network through the primary router when I want to do network related studies.

Primary Router
- IP Address: 192.168.0.1
- connected directly to cable modem
- can allot IP addresses from *.2 - 254

Secondary Router
- IP Address: 192.168.1.1
- (when connected) is connected through a port on my primary router
- can allot IP addresses from *.2 - 254

I installed the 64bit server version of Debian Wheezy using the net install disk. When I attempted to do a net install with the computer connected to my primary router, the net install couldn't complete properly because it wasn't able to obtain an IP address from my router.

I did a fresh install of the OS with my computer connected to my secondary router. The install finished with no problems.

When I connect my computer to my primary router, I am not able to get an IP address.

When connected to my primary router I have
- configured the /etc/network/interfaces file to full DHCP using the the following settings

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp  

-configured the /etc/network/interfaces file to a static IP using the following settings

auto lo  
iface lo inet loopback

dns-nameservers 192.168.0.1

iface the0 inet static
    address 192.168.0.15
    netmask 255.255.255.0
    gateway 192.168.0.1

I have restarted my network settings each time by running services networking restart and also by restarting my computer.

My computer is not able to connect to the internet through or receive an IP address from my primary router.

I have edited the /etc/resolv.conf file so that the nameserver in the file is 192.168.0.1.

I have attempted to change the default gateway using the route and the ip route commands (I have not tried every permutation of this command, but only what I could find on the Internet).

I have used the ethtool to check the duplexing and speed settings of my network card.

There is only one DNS on my home network and that would be my primary router. That only changes when I connect my secondary router to my primary router.

When I connect my secondary router to my primary router and then connect my computer to the secondary router (using DHCP settings for the /etc/network/interfaces file) I am able to connect to the Internet, scan ports, change Internet settings and ping public websites.

However, whenever I connect directly to my primary the computer is not able to obtain an IP address, and commands like services networking restart and route return messages like NO DHCPOFFERS received and RTNETLINK answers: File exists or SIOCADDRT: No such process.

Question
Why won't my computer connect to the internet if:

  1. -I connect it directly to my primary router using DHCP settings, when every device on my home network has a unique hostname
  2. -all other devices connect to the primary router with no problems (there are currently only 3 devices connected and I believe I have set the max for 15 total devices)
  3. -the computer that I would like to connect to the Internet connects successfully when daisy chained through my secondary router
  4. -I have another computer that is running Debian (64bit server version however this second computer has XServer installed [it boots directly to the command prompt by default])

I believe that the problem has to do with my computer defaulting to 192.168.1.1 to obtain an IP address because that was the one that worked for the net install. However, if this is the problem I do not know where to change this and what files or programs might be making these settings persists regardless of the other changes I make to the system.

  • If you configure for the static IP address and connect to your primary router, can you ping that router successfully? – roaima Mar 15 '15 at 19:49
  • Configuring the computer to use static IP settings on the primary router does not allow me to ping the router. – Dodzi Dzakuma Mar 15 '15 at 19:57
  • Then I would suggest that it's either the port on your primary router or the cable/router combination – roaima Mar 15 '15 at 20:43
  • A cable router combination? I'll connect my computer directly to the cable modem and see if I'm able to get an IP that way. However, just like I stated previously, all ports on my router work properly. I have tested different devices and they work through each of the ports. – Dodzi Dzakuma Mar 15 '15 at 20:46
  • No, not a "cable router", I mean "the cable or the router, or some combination of the two". – roaima Mar 15 '15 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.