I am running Ubuntu 11.04 on a Sony Vaio. I am using wine 1.3 to run a rather complex yet archaic gaming program, "Pirates of the Caribbean" (2003; not based off the movie). I started it up and after five minutes it crashed. I unplugged the computer, and when I tried to run the program it crashed and an error came up saying "runtime error! abnormal program termination". Also I created a link to the executable on my desktop and when I tried to load it that way it crashed loading PCS_control.dll and a log file showed up with the content:

Scanning current directory
Loading modules...
Loaded 0 
Initializing CORE...
User Rised Exception
no 'engine.ini' file

I think this report is superficial -- I know that there is an engine.ini file and that it is not corrupted because I tried recopying from my other computer. I also happen to know the above directory does not exist. How can I get this game to run?

P.P.(post, post) when I run engine.exe on the computer while its not in the directory with all of the program files it still says runtime error, maybe when the program crashed it somehow damaged a driver...

P.P.P. sorry I might have made a mistake, it crashes loading directX 8

P.P.P.P. This time I tried running pirates, The Loading screen said "InitDevice::CreateDevice, This Technique is not supported by your device" What does This mean and if possible, how may I fix it? Thanks for your input.

  • 2
    Unfortunately "Game crashes in Wine" is the single most common observation about using wine. – rozcietrzewiacz Aug 19 '11 at 16:42
  • That wasnt my title, someone edited it – Edmund Doyle Aug 19 '11 at 16:43
  • I wasn't referring to the literal content of the title (or, especially, blaming you for it), but to the practical experience with wine :( – rozcietrzewiacz Aug 19 '11 at 16:46
  • The crash actually wasn't the problem, it is a problem but its due to the complex nature of the game not wine – Edmund Doyle Aug 19 '11 at 17:32
  • It crashes in windows as well... – Edmund Doyle Aug 19 '11 at 17:32

Wine is a wild beast.

I checked the WineHQ page for your game, and the latest Gold rating was on Ubuntu 10.10 (not 11.04). However, a user was posting some issues with DirectX as well. It seems like you're given the option to install DirectX 9 during the installation of the game? What did you select?

As per the link in the user's post, I would read this article about DirectX in wine, it might help. It seems you're using 8, try upgrading to 9?

Final thought: Like I said above, Wine is tricky when it comes to stuff like this. Have you considered simply running a VM with Windows installed? Assuming your laptop has 4GB of memory, you shouldn't have a problem being in a Windows environment for a little while you play your game, then you switch your resources back to good ol' nix.

  • I dunno, VirtualBox doesn't play nice with some games. I dual boot instead – TheLQ Aug 23 '11 at 3:06
  • Believe it or not this game actually -- despite the fact that it was designed to run on windows -- will not run on the windows vista operating system. The online conclusion is that the game is too old to run on HD format screens, wine seems to have a solution. One last thing, If I uninstall then reinstall the program; it will work once, any thoughts on why this happens? Thanks for the Advice. – Edmund Doyle Aug 23 '11 at 20:07

Okay... here is an idea. Just a thought mind you. Install XFCE as a secondary desktop environment. It has less of a hardware footprint, so it may be what you need for that extra bit of stability.

  • Try to acomodate me if I am wrong, but I think the first time the program runs it must change a configuration file that stops it from running. Is there a setting I can change to prevent this, if I am right? – Edmund Doyle Aug 21 '11 at 21:44
  • I tried but it did not work. – Edmund Doyle Aug 22 '11 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.