1

I am trying to install synergy from here. When I run it I get the error:

system tray unavailable, quitting

I am running Freya.

Any help would be appreciated or the name of different software to share my mouse and keyboard with a Windows machine.

2

I ran into this same issue. I am using Windows 8 as my server, and Elementary OS as the client. Not sure if your setup is the same.

I used the Synergy command-line commands to start it in a Screen session;

I installed Screen (sudo apt-get install screen). Then I opened a Screen session using "screen -S synergy", and named it synergy so I knew what the screen session was for.

Then I ran the following command to start Synergy: synergyc -n NAME OF ELEMENTARY OS COMPUTER -f NAME OF SERVER.

I then closed my Screen session using Ctrl+A+D.

Screen manual page found here. Really the only tags you need is -S then the name, and -r to reattach the screen.

The synergy client commands are found here.

0

The version from apt-get (1.4.12) in Freya should be working fine - just do sudo apt-get install synergy

0

The last time i checked (probably around august 2015) the version of synergy available from the repo was ancient.. i got version 1.7.4 compiled, but 1.7.5 throws an error at me and doesnt actually compile the synergy executable.. but anyway, i got 1.7.4 easily running on eOS Freya by sudo apt-get installing synergy for the dependencies, but just using my compiled 1.7.4 version autostarted at boot.

i havent even checked the changelog for 1.7.5 yet, but i have an issue with the client randomly disconnecting from the server even though the log says its still connected, tried on 2 different versions of ubuntu, but it works on windows.. i donno

0

try installing sni-qt:

sudo apt-get install sni-qt
  • This solution worked for me. – valkirilov Dec 6 '16 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.