2

Opening google-chrome-stable from the menu does nothing except for a slight twitch of the icon. Running google-chrome-stable via the terminal does produce some interesting output, though.

$ google-chrome-stable
[31450:31450:0315/120013:ERROR:process_singleton_posix.cc(277)] Failed to create /home/marshall/.config/google-chrome/SingletonLock: File exists
[31450:31450:0315/120013:ERROR:chrome_browser_main.cc(1209)] Failed to create a ProcessSingleton for your profile directory. 
This means that running multiple instances would start multiple browser processes rather than opening a new window in the existing process. Aborting now to avoid profile corruption.
1

Could also be a broken link in the .config folder. (~/.config) Delete the google-chrome (broken), then try opening chrome. (At least, that's what worked for me.) (Since ~/.config/google-chrome is broken, it's not recognized as a folder, but a file. Rather that perform the operation in Nautilus/Nemo/Thunar, try sudo rm ~/.config/google-chrome in your terminal of choice.) Good luck.

  • 2
    There shouldn't be any need to sudo to remove a file physically in your own home directory. – Michael Homer Nov 8 '15 at 6:27
1

Had the same issue, and many places had no real answer for me. I discovered that it was because NSS was out of date:

[22506:22543:0213/031311.031825:FATAL:nss_util.cc(631)] 
NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. 
Please upgrade to the latest NSS, and if you still get this 
error, contact your distribution maintainer.

Ran the following and Chrome no runs:

sudo apt-get install libnss3
sudo apt-get update

To test, since you are in the terminal anyway:

google-chrome
0

Try these:

  1. Run Terminal.
  2. sudo nautilus
  3. In menu view check: Show hidden files OR Ctrl+H.
  4. Find in your'e home folder .config
  5. Right click on folder google-chrome then properties.
  6. Go to permissions (in the middle).
  7. Change owner, group to your user
  8. In the same window go to advanced permissions.
  9. Take every privilege to you user.
  10. Now run chrome.

Good luck!

0

Figured out what was wrong by deleting one by one thing from ~/.config/google-chrome/Default and, of course, it was the very last thing.

rm -rf ~/.config/google-chrome/Default/Web\ Data*

It happened several times since the first time it happened and the rm trick worked for me every time. I'm on Debian stable.

Please upwote this if it works for you as I failed to find this for a few hours.

protected by Community Jul 25 at 18:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.