70

I pressed something around my mouse pad (keys in the altgr region+mousepad - quite possibly multitouch) and suddenly the whole X11 display zoomed around 10%. That means I can see 90% of the 1920x1080 screen in a somewhat blurry version. When I move the cursor, the 90% follows the cursor, so by panning around I can see everything on the screen. Since it applies to everything my guess is that it is caused by xfwm or Xorg.

If I suspend the machine, it seems to go away in the lock screen, but when the lock screen is unlocked, the blurriness and zoom re-appears. Taking a screenshot grabs what is displayed on my screen (i.e. the 90% but scaled to 1920x1080).

I can see the usefulness of this in certain situations, but I would really like to exit it (other than rebooting).

I use xfce on Linux Mint.

2
  • 2
    You could even disable the zoom feature, see this question.
    – jarno
    Jul 7, 2020 at 13:58
  • Not sure if this is related, but I somehow ended up with an extremely large InitialZoom=6.327399706912535e+119 in my .config/kwinrc file, changing that to 1 solved my 'stuck in zoom' problem Aug 21, 2021 at 20:50

5 Answers 5

113

Alt + scrollwheel.

So in my case, I had pressed Alt + two fingers on the mouse pad.

2
  • 6
    PHEW! That's a relief.
    – A. B.
    Jan 26, 2021 at 6:05
  • It works, but in my case, only after logging in. on the logging screen works Only the Alt+Windows+8keyboard shortcut (@Lin's answer). Jan 4 at 10:44
15

To Turn on or Turn off Zoom within login screen,
you may use: Alt+Windows+8.

6
  • 1
    Not every keyboard that is being used with Linux has a 'Windows' key ;-)
    – Time4Tea
    Feb 26, 2018 at 22:44
  • 2
    @Time4Tea That's all very nice and elite and superior for you to say, but alt+super+8 does indeed toggle a global screen magnifier in ubuntu 18.10. Feb 24, 2019 at 5:04
  • 1
    This saved me thanks -- zoom is a really poorly implemented feature in Ubuntu 18.04, acessibility my a$$. :'D
    – mitchus
    Aug 14, 2019 at 8:35
  • 1
    I'm using only the mousepad on my laptop, and the "accepted answer" of Alt+scrollwheel didn't work for me. This suggestion worked, on Ubuntu 20.04.
    – mcduffee
    Jan 15, 2021 at 11:19
  • 1
    This works in PopOS as well, but take not they it's 8 not F8. I initially misread that. Sep 12, 2021 at 15:51
3

This zoom mode is traditionally bound to Ctrl+Alt+Keypad + to zoom in and Ctrl+Alt+Keypad - to zoom out. These keys are not available if the DontZoom option is set in the ServerFlags section of /etc/X11/xorg.conf.

This feature is operated by the server, I don't know how to set it from a client. The xrandr command may influence it with its --scale option, or some other option may be able to reset the zoom setting; I'm unfamiliar with the interactions between the old-time server zoom and the modern RandR support.

2
  • I thought it might be that, but ctrl-alt-+ and - do nothing and also was clearly not the keys I pressed. It would also require several mode lines (or equivalent), and there is only one resolution. But I found the solution: Alt+scrollwheel (which on my mouse pad is two fingers). ubuntuforums.org/showthread.php?t=2208553
    – Ole Tange
    Mar 16, 2015 at 7:24
  • Also the Xorg-zoom mode would not explain why the zoom is disabled at the screen lock.
    – Ole Tange
    Mar 16, 2015 at 7:27
1

Try using xrandr.
My problem (with Linux Mint and losing the margins to overscan on a TV) was corrected that way.

1

I had the same problem. As mentioned above alt + scroll button or alt + two-finger tap has worked for most but didn't work for me. I had to go to System Settings > Desktop Effects - workspace behavior. In there the Accessibility section has a Zoom option. I had to disable that option

Edit: I am using KDE and not Xfce but was facing the exact same problem

3
  • That is because you use KDE, not Xfce, right?
    – jarno
    Oct 24, 2020 at 7:52
  • As for disabling the feature in Xfce, see here.
    – jarno
    Oct 24, 2020 at 8:21
  • @jarno, Yes you are correct : )
    – CodeNinja
    Oct 24, 2020 at 15:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.