2

I installed Debian Wheezy 7.8 on a Lenovo G50-70 x64, it seems that I don't have the driver for my wireless card installed, the output of iwconfig:

lo no wireless extensions.

eth0 no wireless extensions.

Here's the output of lspci -nn:

01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 10)
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:b723]

As you can see my ethernet controller has the driver installed and it's working fine, but the Network Controller which is my wifi card is not installed.

I tried looking in the device database of debian for the vendor and device id 10ec:b723 to find which module I need to install but I couldn't find it, although I found my ethernet controller and which module it requires, does this mean that this card is not supported ?

While searching I found the firmware of RTL8723BE in the packge firmware-realtek for Jessie so I installed it from wheezy backports, but I don't know if this is the driver or not, and nothing has changed.

I also found this repository on github rtlwifi_new and tried installing the driver from source, but I got these errors when I ran make:

make -C /lib/modules/3.2.0-4-amd64/build M=/home/peter/rtlwifi_new modules
make[1]: Entering directory `/usr/src/linux-headers-3.2.0-4-amd64'
  CC [M]  /home/peter/rtlwifi_new/rtl8192cu/hw.o
/home/peter/rtlwifi_new/rtl8192cu/hw.c: In function ‘rtl92cu_update_hal_rate_mask’:
/home/peter/rtlwifi_new/rtl8192cu/hw.c:2094:25: error: ‘struct ieee80211_sta’ has no member named ‘bandwidth’
/home/peter/rtlwifi_new/rtl8192cu/hw.c:2094:40: error: ‘IEEE80211_STA_RX_BW_40’ undeclared (first use in this function)
/home/peter/rtlwifi_new/rtl8192cu/hw.c:2094:40: note: each undeclared identifier is reported only once for each function it appears in
make[5]: *** [/home/peter/rtlwifi_new/rtl8192cu/hw.o] Error 1
make[4]: *** [/home/peter/rtlwifi_new/rtl8192cu] Error 2
make[3]: *** [_module_/home/peter/rtlwifi_new] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.2.0-4-amd64'
make: *** [all] Error 2

So what should do in this case, where can I find the module I need for this card ? and If this Github repository is what I need, how can I fix these errors ? I already have build-essential and the linux headers installed.

Update

After searching for a while I found that the rtl8723be.ko module is available in the the kernel version 3.16 of the testing release Jessie, is it safe to update my kernel using the Wheezy backport ?

Update 2

When I run modprobe rtl8723be I get the following:

FATAL: Module rtl8723be not found.
  • just a thought, after your install of firmware-realtek what says sudo modprobe rtl8723be ? – taliezin Mar 13 '15 at 11:28
  • @taliezin it says FATAL: Module rtl8723be not found. – Pierre Mar 13 '15 at 11:40
  • than what is installed? apt show? And for the second part did you do: sudo apt-get install build-essential linux-headers-generic linux-headers-uname -r, because I successfully build it but for 3.10 kernel, but as istated kernel shuld be > 3.0? – taliezin Mar 13 '15 at 12:15
  • @taliezin my kernel version is 3.2.0-4-amd64. – Pierre Mar 13 '15 at 12:26
  • I understood that: /lib/modules/3.2.0-4-amd64 thats why I am asking if everything for building modules is installed. – taliezin Mar 13 '15 at 12:27
0

In fact, you want the r8168-dkms package which is a patched driver specifically for your wifi chipset, however, it is not available for wheezy. It depends on dkms >= 2.1.0.0 and you should have 2.2.0.3-1.2 so it should just install fine.

0

I think you missed readme starting info i.e. in this repo

This code will build on any kernel 4.2 and newer

this is kernel code compatible with 4.2 and higher. So suggestion for you will be

  1. update kernel to 4.2 or newer either by debian repo i.e. using aptitude
  2. revert to earlier commit and try compiling. easier way to test will be quickly switch to test branch and compile as test branch is valid for 3.0 and newer.

let me know if you need exact commit id.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.