2

I've been running Arch for almost a year now, and my audio was working great until I started messing around with things (>.>) The reason I started messing around with things is because I want to get audio support working in Skype, which I was able to hear the sound effects Skype makes, but was unable to to use the microphone. On a side note, my hardware is a MBPr late 2013.

So I decided to open "Volume Control" and check out the configuration options. Under the "configuratoin" tab in the "Volume Control" app I have two devices I can configure. I can configure the HDMI device or the "Bult-in Audio".

Now this brings me to my first question, which "Built-in Audio" configuration option should I choose? I obviously want to be able to use the built-in microphone along with the speakers, so I chose, "Analog Surrond Output 2.1 + Analog Stereo Input".

volume control

However, all the options I can choose from are the following,

  • Analog Stereo Duplex
  • Analog Stereo Output
  • Digital Stereo (IEC958) Output + Analog Stereo Input
  • Digital Stereo (IEC958) Output
  • Analog Surround 2.1 Output + Analog Stereo Input
  • Analog Surround 2.1 Output
  • Analog Surround 4.0 Output + Analog Stereo Input
  • Analog Surround 4.0 Output Analog Stereo Input

When I have this option selected or any option selected for that matter I can no longer hear any audio coming from the speakers.

When I open alsamixer it states the audio device as being "pulseaduio", and the "Master Front" doesn't appear to be muted.

Also, I can't hear anything running speaker-test.

Any help on how I can troubleshoot my audio situation would be greatly appreciated.

0

The problem was rather simple, I needed to select Analog Stereo Duplex to get the mic and speakers working for things like Skype calls.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.