4

I am trying to setup my wifi network in Arch Linux ARM to auto-connect at home and office. But it is not always connecting automatically as intended.

netctl list
* wlan0-Spaceship
  wlan0-Cremehead

I am not quite sure how to debug this problem as it is acting very randomly. I have enabled both wlan0-Spaceship and wlan0-Cremehead which i assume should be the most important thing?

UPDATE 1

I tried to enable the netctl-auto service:

$ systemctl enable netctl-auto@wlan0.service

But it has not solved the problem, but i see these two FAIL statements:

$ netctl-auto list
  FAIL
  FAIL

  $ systemctl --type=service
  netctl-auto@wlan0.service             loaded active running Automatic wireless network connection using netctl profiles
  netctl.service                        loaded active exited  (Re)store the netctl profile state
* netctl@wlan0\x2dSpaceship.service   loaded failed failed  Automatically generated profile by wifi-menu
* netctl@wlan0\x2dCremehead.service loaded failed failed  Automatically generated profile by wifi-menu

UPDATE 2

I just found out that i have problems enabling a connection. I need to do this two times to start.

Mar 11 10:05:39 proto-pi2-sandbox network[578]: The WPA supplicant did not start for interface 'wlan0'
Mar 11 10:05:39 proto-pi2-sandbox network[578]: Failed to bring the network up for profile 'wlan0-Cremehead'
Mar 11 10:05:39 proto-pi2-sandbox systemd[1]: netctl@wlan0\x2dCremehead.service: main process exited, code=exited, status=1/FAILURE
Mar 11 10:05:39 proto-pi2-sandbox systemd[1]: Failed to start Automatically generated profile by wifi-menu.
2

The functionality you are looking for is through nectl-auto. netctl is for auto connecting on boot or whenever the service through systemd is started where netctl-auto connects to the profiles enabled in its own manager and you would only have netctl-auto@[interface].service enabled.

netctl

netctl-auto

  • Would this not create redundancy as there are profiles as services from netctl already? – JavaCake Mar 11 '15 at 7:28
  • See my primary post. I have updated with info! – JavaCake Mar 11 '15 at 10:01
  • So, in your update 2 it looks like you still have the netctl profiles enabled. You should ONLY have the netctl-auto profile enabled and started you should disable all oter netctl profiles. Then use netctl-auto list to make sure your profiles are ready to auto switch with netctl-auto. – Dean Galvin Mar 11 '15 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.