4

I tested OpenSuse KDE 13.2 and Netrunner 15 (which also uses the KDE desktop) and none connects to the internet automatically.

OpenSuse does not even remember the wifi password.

How to make it remember it and connect to internet by Wifi automatically on startup?

Netrunner 15 remebers the password but needs me yo manually select my wifi network after startup. In the network settings, editing my connection, the option "Automatically connect to this network", under General settings, is checked.

I want to make KDE in all cases to be able to connect to the internet automatically after startup.

5
  • 1
    Have you checked "All users may connect to this network"? Commented Mar 10, 2015 at 14:39
  • 1
    @TheBlackCat - that's the answer for Netrunner. You should post it as such.
    – user32012
    Commented Mar 10, 2015 at 15:31
  • 1
    I don't know Netrunner, it is the answer for KDE's implementation of Networkmanager. Commented Mar 10, 2015 at 15:39
  • 1
    Yes, in "Edit Connection" of Network Manager, there are two options availalbe, that should be checked for your case: "Automatically connect to this network when it is available" and "All users may connect to this network". Commented Mar 10, 2015 at 16:38
  • @TheBlackCat - I mean the problem as I encountered it with Netrunner (in Kubuntu, for example, it seems that is checked by default). Please post your comment as answer or this will possibly stay with no answer.
    – user32012
    Commented Mar 10, 2015 at 21:17

4 Answers 4

3

You can check "All users may connect to this network" in General Settings. This will automatically connect on boot.

1
1

I have solved it by doing two things from Network Manager GUI:

  • Check "All users may connect to this network" on General configuration tab.

  • Choose "Store password for all users (not encrypted)" on Wi-Fi security tab.

I am using Manjaro KDE and SDDM, Wi-Fi is connected at the login screen so i can VNC it to login with any user.

0

Remember to check "All users may connect to this network" in KDE Edit Connection (tab General configuration).

I use Kubuntu 14.10 and the Network could not connect wifi automatically. This bug has been reported here but it's still unsolved.

0

As of 5.24, you must click the Networks icon on the panel and then select settings (looks like sliders). Select the connection, then Edit, then do as above.

You must log in to answer this question.