1

I've been trying out a trackball mouse and I find that it is entirely too sensitive, so I tune it down by setting its Device Accel Constant Deceleration to 1.5, I feel like this dials in the X axis fine, but my Y axis motions are underwhelming.

Simply put, is it possibly to configure X and Y sensitivities separately?

My environment is fairly stock Linux Mint 17.1, so Ubuntu-trusty–like, Debian, Gnome 3, and the rest of the stack that I am less familiar with.

2 Answers 2

2

The setting that you need to change is the
Coordinate Transformation Matrix (144).

In the following examples the mouse is device id=9 and the property number of the Coordinate Transformation Matrix (of my mouse) is 144 as you can find out with xinput list-props 9

Set it to default:
xinput set-prop 9 144 1 0 0 0 1 0 0 0 1
Make X 5 times faster than Y:
xinput set-prop 9 144 5 0 0 0 1 0 0 0 1
Make Y .2 times as fast as X:
xinput set-prop 9 144 1 0 0 0 .2 0 0 0 1
Rotate 45 degrees:
xinput set-prop 9 144 .707 -.707 0 .707 .707 0 0 0 1

1
  • Truly you must be a wizard. Give me a little time to confirm this, I don't use that particular mouse much but next I do I will give these a go! :) Commented Feb 8, 2016 at 6:09
0

Had the same problem with a Logitech M510. The speed in x direction was annoyingly faster than in y direction.

Setting the matrix like this worked like a charm:

xinput set-prop 11 136 0.6 0 0 0 1 0 0 0 1

11 is the ID of the mouse, 136 the ID of the mouse's Coordinate Transform Matrix. I obtained these values by calling

xinput

and then

xinput -list-props 11

Cheers!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .