0

I tried for at least 3 hours to mount my Network Share to my Pi... I searched on many posts and tried so many things. But nothing worked...

I want to mount my Share over the /etc/fstab file so I edited the file with sudo nano /etc/fstab and added the last line of code:

//HOGWARTS-WIFI/Elements /mnt/share cifs username=msusername,password=mspassword,uid=1000,gid=1000,iocharset=utf8 0 0

When I checked with sudo mount -av this error appears:

mount.cifs kernel mount options: ip=192.168.2.1,unc=\\HOGWARTS-WIFI\Elements,iocharset=utf8,uid=1000,gid=1000,user=msusername,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

What do I need to do?

0

Whenever I run into issues mounting CIFS shares I generally turn debugging on.

See: https://wiki.samba.org/index.php/LinuxCIFS_troubleshooting

One thing I ran into recently is that actual Windows CIFS shares usually do not require the domain name. However, on a samba file share I have that authenticates (using kerberos) against a domain control you must include the domain portion. As an example here is what I have in my fstab (with comments):

Share served by Windows Server 2008:

//appdeploy/c$ /mnt/appdeploy_admin cifs noauto,username=my.username,uid=user,gid=user 0 0

Share served by Samba using kerberos authentication:

//storage/TSC /mnt/TSC-STORAGE cifs noauto,username=my.username,domain=local,uid=user,gid=user

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.