0

This question already has an answer here:

When I start the terminal in my xfce Destop environment a black winodw about a quarter of the screen size appears, if I want to expand it to full screen size I have to click on the "+"-shaped symbol in its upper right corner. Is it possible to do the same without clicking onto it, just by using the command line ? enter image description here

marked as duplicate by muru, Michael Homer, Stephen Kitt, Anthon, mikeserv Mar 9 '15 at 22:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

I assume you find the fact that the window starts so small annoying, and do not actually want to programatically change the window size.

The shortcut to maximize any window is alt+F5. If that is too inconvenient you can change it via the system settings, or just drag the window up against the top edge of the screen, after making sure you have that activated in settings -> window manager tweaks -> accessibility -> automatically tile windows when moving to screen edge

You can also change the default size of the terminal, which for xfce4-terminal is done by selecting

edit -> preferences -> "appearance" tab -> Default geometry

This will not maximize your window by default though, just set it to the given size, so you might prefer the above solutions.

Not the answer you're looking for? Browse other questions tagged or ask your own question.