0

I'm trying to dual boot OS X and elementary OS on a Mac. I've followed e.g. these instructions. The first question is this: I have not once got the "install alongside" option so I've manually created root and swap partitions. Is there a reason for this? I believe I should get "install alongside Mac OS X"?

Anyway, the install goes through just fine with manual partitioning, but when I reboot after the install, I get the (initramfs) prompt. If I just reboot again after the (initframs) prompt I only get a black screen or the underscore blinking in the top left corner. I ran boot-repair which only resulted in grub rescue after reboot. I also tried this (the 1st answer). So the second question is how to fix this?

I'm using rEFInd. Another question is, in case I can't get it to boot properly, how do I remove the extra boot options from rEFInd that stay there also after deleting the linux partitions.

1

When you partition your hard drive to prepare for the install, just shrink the Macintosh HD partition and leave several gigabytes of free space (you may need to create a partition and change the format to "free space"). Elementary OS will format and utilize this free space while itself allowing you to install it alongside OS X.

  • Wish it was that easy. Did you read what I wrote? 1) of course I shrinked the OS X partition 2) I did not get the install alongside option so I created the partitions by hand 3) nothing seemed to go wrong in the installation 4) the above initframs thing happened anyway. Anyway, that was with eOS Luna, I had better luck with Freya, don't know why but it works. – Roope Apr 19 '15 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.