I have a linux machine and a windows machine, the linux machine has a samba share with a .exe file on it. I can read and write files from the windows machine to the samba share, but I cannot execute the .exe file. How can I setup samba to allow me to execute it?

  • 2
    I am indeed trying to execute it on my Windows Machine, the error is: "Windows cannot access \\CUBE-SERVER\share\xowa\xowa_64.exe You do not have permission to access \\CUBE-SERVER\share\xowa\xowa_64.exe. Contact your network administrator to request access."
    – jojo_bacon
    Commented Mar 7, 2015 at 4:50
  • 1
    Can you list the other files in the \\CUBE-SERVER\share\xowa directory on Windows? Can you read and write files in that directory?
    – Jason C
    Commented Mar 7, 2015 at 4:56
  • The files are a bin folder, a user folder, a licence file, xowa.gfs, xowa_64.exe, xowa_build.gfs, xowa_build_windows_64, and xowa_windows_64.jar. I can read a write files to the directory, I tested this by making a txt file, typing in it, saving it, then reading it.
    – jojo_bacon
    Commented Mar 7, 2015 at 16:42
  • It may be a windows policy thing. (That's just about the extent of my windows knowledge :)
    – wurtel
    Commented Mar 9, 2015 at 12:27

2 Answers 2


This behavior because of a security policy of the modern Samba. Fix by adding this line to your /etc/samba/smb.conf under [global] section:

acl allow execute always = True

Source: Samba's Wiki.

  • 2
    This solved a problem for me running VS2017 on a Windows 10 vm where the solution was on a Linux mapped network drive. Commented Jun 13, 2018 at 21:10
  • 2
    Is there any more granular way, to say make only certain filetypes executable, like exe, bat, and msi?
    – Elliott B
    Commented Jun 17, 2018 at 7:03

For me it worked by just adding the executable tag to the file.

chmod +x file.exe

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .